shadowing weirdness

See image and/or .blend file. The lower part of the mesh is in shadow for no apparent reason.

It’s a simple test scene with two point lights. If I render this without shadows it’s ok. I’m at a loss as to what might be causing this behaviour. Any help would be appreciated.

Note: I have stripped the .blend of textures and high-poly meshes to make the file smaller, but the problem persists, so it shouldn’t matter.

Attachments


streetlight3_pack.blend (63.8 KB)

The curve circle is casting a shadow. Put that on another layer or delete it. I don’t know why it casts a shadow. But anyway there are other ways to animate the camera around in a circle.

EDIT: Or of course, duh, just toggle off the rendering of the circle.

The CurveCircle (which the camera is constrained to) is a solid disc (change drawtype from Wireframe to Solid to see). Just enable 3D in the Curve panel to fix this

Edit: See above for better suggestion.

In Curve and Surface, flip on 3D, that seems to fix it for me.

Edit: Damn you, Sago! You know I actually wrote out a two-paragraph post on normals before realising that wasn’t what was asked!

lol. You guys suck or either are too slow :stuck_out_tongue:

Wow. I would never have thought of that. Thank you guys so much!