shadows in alpha channel?

shadows is should be semi-transparent in alpha channel. how to do this?

You have to enable OnlyShad for your floor material. You can find it in material buttons -> Shaders tab (just right of spec value).