Shadows kicking my butt!

I’m having a problem with my model’s shadows. :frowning:

The shadow appears solid for the whole object. But, what I want it to do is be lighter where the shadow is cast by the glass so that the internal part’s and the end piece’s shadows stand out.

Here’s what the texture’s settings for the glass looks like.

Any suggestions?

It’s a common misconception to think that setting receive transparent shadows in the casting material produces transparent shadows. I had the same problem when I began using blender.
To get the result you want you have to set receive transparent in the material where the shadow is being cast. The table/ground/greenish tint surface in this case.

Hope this helps.

Thank you so much! I feel so dumb for not realizing that lol.

Not at all.
Many ppl have the exact same issue. I was very frustrated by this until I got a book that explained this much. Of course the field back then was named just “TraShadow”…
Good luck with your project.