shadows not showing

Hallo. i have edited my post putting a smaller and so easyere to download file.

Im very new to lightning. Ive created a scene but want lighting with atmospheric lightning and have ligthning from a plane behind my scene plus ive added a sun in the hope ill get shadows. But no shadows. What am i doing wrong. is it the atmosphere lights or the plane? . Im not sure. Have i missed a setting in the sun lamp? or is it just way to many lights?

my blend file: http://www.pasteall.org/blend/42588
lisa

i have edited post and put on easyere to download file: http://www.pasteall.org/blend/42588

There are several issues with your scene.
The position of a sun lamp is completely irrelevant, as it is always seen as infinitely far away. Its rotation is all that matters.

This has two unfortunate effects in your scene:

(1)
Your background plane is in the way of the sun light, i. e. it casts a shadow over the entire scene. So, disable shadows on that one.

(2)
It’s hardly ever a good idea to add a Volume Scatter to the entire world. As said above, the sun is infinitely far away. If you add Volume Scatter to everything, the light will have to pass through an entire “universe” of volume scatter before it reaches your scene - meaning it doesn’t reach it at all.

It’s preferable in most cases to enclose the scene in a finite box with Volume Scatter added to it and remove Volume Scatter from the world.

In addition to that, your AO overpowers everything and eliminates all shadow nuances.

This is your scene with the aforementioned changes and AO turned off:

https://dl.dropboxusercontent.com/u/27650383/03-07-2016%2011-46-50.png

Hallo IkariShinji

i have tried playing around with ur suggestions but still no shadows. Could you give me more details on how to do this. explain how to do the lights>

Those are your lights. I did not change your lighting setup at all…

All I did was:

  • Disable AO in the World tab.
  • Delete the Volume Scatter node in the World material.
  • Add a cube to enclose the scene and connect a Volume Scatter node to the cube’s material.
  • Disable shadow casting for the background plane (Object tab > Cycles Settings).