Shadows only problem...

Heya!

I’m trying to make an object cast shadows on things in my street. So I rebuilt the street from the cam’s POV and planned on using shadow only rendering to accomplish this. The result is not what I expected based on my previous experience with shadow only rendering… the shadow only layers seem to be casting shadows on each other and I’m not sure how to prevent this…

Attached are the reconstructions with normal and shadow only shading. The cylinder in the center is the only thing that should be casting a shadow…

For good measure I turned off all casting properties on the receiving materials… tried everything else I could think of. The light source is a “sun” lamp.

Thanks for reading and all advice is appreciated…

Here are the attachments I forgot…

Attachments



you need to turn off traceable in the options and casts buffer shadows, and cast aproximate in the shadows panel on the shadows only material.

Thanks for the reply, and sorry for prolonged absence…

Tried your suggestion. In the first images, I had all those settings but disabling traceable. But when I turn traceable off, the casting object’s shadow doesn’t show up either. Its like… traceable both allows it to cast and receive shadows. I need this to be all the objects representing pieces of my original picture in 3D space to be completely transparent other than the shadows the 3D models I am compositing in cast. The more research I do, the less likely it looks that this is possible… any ideas?

Ideally, I also need the “shadow only” layers to obscure any object that is behind it as well in the final render. I want to be able to drop the output into after effects on top of my model image and just have it work… I’d post the blend this is for, but with all the baked physics on thousands of objects, the file is 12 gigs.

Playing with it some more, I’ve been having some weirdness with the shadows not appearing on the Shadow Only material when using a sun lamp. They appear on and off when the shadow casting object is of a certain scale or distance of a shadow receiving object. so I’m thinking it’s something with the sun lamp. Maybe try to mimic the sun lamps lighting results with an Area Light.
As for the material they still seem to be working for me.

The shadow receving material should have Traceable disabled with Shadow Only, Receive Transparent, if you have them, and Receive on.

The casting should be a standard configuration with Traceable enabled and all the casting goodies.

Something with the sun lamp… I’ll play with that. BTW, you’ve been a huge help to me, LoMac. You rock sumthin’ fierce.

As far as obscuring objects with transparent layers is concerned…? Ideally, when I output this, I will have one layer that is JUST the shadows, and another render layer that is just the visible objects, but since there will be so many objects, it will be impossible to mask them properly in After Effects… is there a way to make the second render layer properly obscured by the transparent layers? The only solution I could figure for this is to do a second render and make the transparent layers chroma green with emit turned all the way up. That way, I could easily take out the transparent bits, then track matte a clean pass of just the objects to this chroma trick layer… but that is cumbersome and will take forever in render time… could I trouble you for more lifesaving advice?