Shadows, Radiosity & Curves.


(Chest) #1

Howdy,

I’ve bleen playing around with radiosity, and I have a question or two.

http://68.41.90.70/images/shadows.jpg

How can I get rid of those triangular shadows?

I was using a curve and then converted to a mesh.
Can I make blender calculate the shadow map indefinitely? I am using straight up radiosity settings, no tweaks.

Thanks,
Chest


(theeth) #2

How can I get rid of those triangular shadows?

Radiosity is face based, so I would suggest using one or two shots of Beauty subdivision before running the radiosity solution.

  • In the Edit buttons, select Beauty
  • Select each face of the curve (the flat side) in turns, and hit Subdivide (Wkey, 1) once or twice.

Can I make blender calculate the shadow map indefinitely? I am using straight up radiosity settings, no tweaks.

I think that if you lower the Convergence setting, the ray will bounce more times, hence making the simulation longer.

Martin


(Jolly Gnome) #3

What a freaky looking Blender! How come it looks like that?


(sten) #4

hmm…

for those shadow artifacts in Radiosity,
it is also possible to play with the buttons:

FaceFilter and Element Filter

I have done it with great result !


(Chest) #5

Thanks for the help guys. Here’s one more:

http://68.41.90.70/images/blender_shot2.jpg

Doesn’t that shadow look strange? Normal shadows don’t look like that.
Looks like it’s inverted.
What’s up with that?

Straight settings once again.

It’s the enlightenment desktop, Jolly!


(tordat) #6

Reduce the distance between ClipSta and ClipEnd.

Explanation: no idea. :-?


(Chest) #7

That did it Tordat, thanks!


(DAK) #8

I seem to be having this same kind of problem myself in radiosity shadows so i’m bringing this message back to top.