Shadows won't render

I have a simple scene of a grape with a circle underneath, and when I try to render it the shadows do not show up. This has also happened with another blend file I started working on, All i did was add a few cubes on a plane and they would not cast shadows. All of my material settings are fine (traceable is checked, cast and receive are checked) but there are no shadows. Here is the grape render, the grape is sitting directly on the circle:

check your lamp settings

wow thanks, all my lamps got set to no shadow for some reason