Shape key glich

Whenever I create a new shape key for whatever reason this happens:

Can someone tell me what in God’s name is happening here?
I’ve attached the .blend file:
Viktorija2 4 advanced rigging.blend (10.3 MB)

Your problems are related to a scaled armature in object mode. Don’t do that or your shape keys will goof up. To see your goof up, make a copy of blend and just do this. Delete all your shape keys. Now that you are back to zero, this is the basis your mesh used to create keys. The first two actually worked because you defined a vertex group to blend with or you did them before the parent operation.

To fix this you need to fix your mesh and armature:

Unparent your mesh from your armature by alt P clear and keep transforms.
Control A visual Transform
Delete your armature modifier in the modifiers tab
Select and then pin your basis shape key.
Enter edit mode. I usually select everything at this point to check it, then tab out of edit mode.
Un pin your basis. You should be able to go now.

Go to your armature and zero out your transforms. alt s, alt g and alt R.
Go to edit mode in your armature:
Adjust your armature to fit your mesh in edit mode only. If you do this in object mode.
you will mesh up your mesh again.

Check all your bones to be sure you haven’t accidentally turned on deform for a control (like your elbow.r
Parent your armature back. Control P with automatic weights.

Good luck.

It worked, thanks.