Shape Key mistake

I made one heck of a mistake… while editing to add some details to this model, I worked on the destination shape key, not the basis.

so, when I went to look at the animation, you can imagine my dismay when I found that all the additional vertices that I added started from their extrusion points, not their final position. Obviously this is operator head space error not a problem with blender.

But, is there a way I can fix this? worst case is copy the shape key back to the basis somehow, then fix, then re-define the cargo door shape key. but, how can I do that?


I’m not exactly sure I get what you mean but are you saying you added vertices after creating shape keys?
You should really not do that. When creating shape keys the topology should stay the same.

Yes, thats exactly what I’m saying… and blender handled it exactly the way it figured it was supposed to, by adding the extra vertici in their original positions (ie from where I started the edit) and then moving them to their final position as the shape key is applied. I rather assume this is because both shapes must have the same number of vertici, (which I knew, but assumed would be added to both shapes in the same spot) but because I made the mistake of working to the shape key instead of the basis, on the basis the new vertici have no position data so revert to the parents I extruded them from.

Which, leads back to the original question (and why if you look the blend is attached) IS there a way to, worst case, redefine my shape key as the basis?

i’m not entirely sure i’m understanding your question - but if you’re asking how to get rid of the basis shape and use your Cargo Doors shape as the new basis, you can just delete “Basis” and rename “Cargo Doors” to basis.

i’m not exactly sure which problematic extrusions you mean, but i’m assuming the flap/hole opening on the top is one of them, since in the basis shape it goes concave? in a case like this, where you have added vertices by accident (or where you’ve just moved some in a shape but don’t like what you’ve done, and realize that you can’t undo any longer), what you can do is this:

select the problem-causing vertices, go to your Basis shape, and bring up the specials menu (W), and select “Blend from shape”. copy these vertices’ placement from the Cargo Doors shape (value of 1.0, but uncheck the “Add” box - that’s not what you want to do). then, still in your Basis shape, bring up the specials menu again and select “Shape Propagate”, and it’ll set the Cargo Doors shape to use these vertex coordinates (as if you hadn’t moved them at all). …or something. you can then edit those verts in your Basis and Cargo Doors shapes.

That is exactly what I needed! Sure the one hatch cover is out of place in basis now, but thats an easy fix compared to how the heck do I find just the vertices I needed when they were all jumbled in on top of each other in basis.