Shared object "" not found. FreeBSD 5.1

When running blender-publisher the following output appears:
/usr/libexec/ Shared object “” not found.
Would appreciate any help regarding this unsolved mystery so I can use blender in FreeBSD.

You need to have OpenGL installed.

You can use glxinfo or glxgears to test OpenGL.

  1. Look for the libs:
    Check /usr/lib and /usr/X11R6/lib for libGL*
    Check find /usr -name “libGL*”
    If you find it, symlink it to /usr/lib/

  2. If you can’t find it, check your X installation. It should come with X.

  3. NVidia are the only company who actually release drivers for FreeBSD (AFAIK) - if you have an NVidia card, install their drivers.

  4. If you still haven’t got any GL, install Mesa. Mesa is a software GL implementation, so it will be as slow as all hell.

  5. Build Blender from source. Especially if you symlink’ed in 1. and you now get errors about missing symbols, and other linking errors.

Good Luck!

I installed py-opengl;Mesa3;Mesa demos;nvidia drivers and still get “/usr/libexec/ object “” not found”.
I see (shortcut) and in /usr/X11R6/lib but no Would it work to ln -s /usr/X11R6/lib/ /usr/X11R6/lib/ ? Why is there no besides blender not working, kpovmodeler gives me a “no openGL support” message. When I run glxgears, i get “Xlib: extension “GLX” missing on display “:0.0”. Error: couldn’t get an RGB, Double-buffered visual”.
Thanks for your feedback.

You can try (in /usr/X11R6/lib)
ln -s
but I can really only see pain coming from that.

You will also need:
Load “glx”
in Section “Module” in /etc/X11/XF86Config

Don’t do this if you don’t have a good working knowledge of vi - your X server might not come back up.

What graphics card do you have? What version of XFree86 are you running?

Mesa3?? Mesa 5 is out. OpenGL really should have been installed with the OS.

This is the only info I found about installing GL on FreeBSD:

In fact, that link looks like a much better source of information than me. :slight_smile:
load “glx” is enabled. Its OK if X crashes, one can always go back and undo whatever using a simple editor such as ee.
It seems that my card nvidia does not support openGL as the above link seems to indicate. I was able to get heretic going. Also nvidia does not use DRI. I have Blender working in windows;Red Hat 9.0 and MDK 9.1. I just wanted it in FreeBSD 5.1 also.
I might be overlooking something real simple, which is usually the case with FreeBSD 5.1. 5.1 is full of surprises and is very different from even 5.0.

What about these drivers:

Can you compile blender from source?

I think you need to recheck your X installation.

First, thank you.
I already installed the latest driver from that site.
I compiled two versions of blender from source. blender-2.28a and blender-publisher-2.25. I also tried pkg_add -r blender which I already previously installed.
I followed instructions from the driver website in regards to Section “Module” and Section “Device”. That Config file is called which is different from /etc/X11/XF86Config. Alas! part of my problem solved. I uncommented Load “glx” and Load “dri” from the XF86Config and am now able to run kpovmodeler and glxgears plus I get the nvidia splash screen, but blender still is looking for that file. It simply is not in my OS anywhere. When I try to launch a newer version of blender from my home directory, I get “libSDL” not found. So the bottom line is I need those libraries. Where I find those libraries is my next quest. Bear in mind I installed the latest nvidia drivers, have the most recent XFree86 server, installed mesa 3 (perhaps mesa 5 would be better) and also installed py-opengl.
There is a lot more info from the nvidia driver site I have to read-- but you did help -THANKS

SDL is from and libGL is from X or nvidia provide their own.

If you have got kpovmodeller and glxgears running, then compile Blender from source and it will use the libGL that kpov and gears are using.

I would assume you mean after unpacking the tarball, to ./ configure; make and make install? You got me confused here because I compiled from source already as stated. Perhaps I should try again after having fixed my other problems. I don’t think you mean compile from the source code which is a much larger file.
I will try it and if it works I will get back.
I also did some searching and someone mentioned to "add XFREE86_VERSION=4 to /etc/make.conf. Another is to include the path to it in the env var: LD_LIBRARY_PATH.
will give it all a try this weekend. Thanks again

I installed blender-devel . A very long compile. i put the executable file in the PATH which was /usr/games . I also added XFREE86_VERSION=4 to my /etc/make.conf (just for the heck of it). I then rebooted. IT WORKS!
I will try another version of blender at some point. I don’t know how stable 2.27 is. Now its time to have fun with blender on FreeBSD.

this is a sort of crosspost, but wtf.:

::I had same problem with 228a on fbsd 4.8, but then I downloaded 227newpy for freebsd from official blender download site , not the devel from fbsd site, and it worked without any hassle on my Ibm with matrox card.

…do you have any tips on how to start blender trough console so it will fit nicely between gnome’s taskbars (like maximized and not fullscreen?)

::perhaps someone knows where to get that misterious or was it a just mistake in official release - perhaps will there be a working precompiled release of 228c for bsd’s?

I don’t use gnome but in Kde you can make the taskbar side either to the left or right and in windowmaker or at least icewm or blackbox it (blender) slides right over the taskbar. In windows it has to be resized to view the bottom buttons and I would suppose you will have to drag the handles on Gnome as well (the larger the screen the better). I don’t find the library an issue any more (check the posts). Just copy the executable from where ever it was installed into the env var PATH that you can locate in the /home/.profile. If it says /usr/game, then just copy it there. In MDK Blender did not work from the distro , I had to download it from the Blender site. Red Hat was easy going and in SuSE it works right out of the box. In Debian ‘Woody’ , it installs but is very unstable and I did not spend time to find out why (yet).

You can open blender in a window with:

blender -w -p x y w h

where x, y is the position of the window (measured from the lower left corner) and w, h is the width and height of the window,


blender -w -p 10 10 800 600

hey, thanks, I know that with switches - use it extensively - I’ve made me a bunch of bat/0x_start.blend combos for various usages under windows (manly for scripting and testing - so blender opens as requested and loads requested custom ‘template’ scene), but I would like just to mimic behaviour as experienced under windows - run it maximized, not fullscreen, between taskbars ( I can do it if I alt/tab to console - I start it from there - and then right-click on blender’s tab and choose ‘maximize’, but this is a sort of hassle ). Maybe I’ll try switches interim, but this may really be done via window manager settings.