sharp export

Hello. whatever i do my models always export with sharp edges. it marks as sharp every edge. i dont get it. i dont mark as sharp. i tried obj and fbx export but its always sharp when i import them back. i added my import and export settings. also my .obj to see if it imports sharp for you too.
Blender 2.78C


heres to obj i exported (9.75 KB)

Are you exporting it flat shaded?

Did you hit smooth shading while in object mode ,before exporting?

no i didnt push any button. so its flat shaded i guess.

If you want a smooth shaded object when you import it, then you need to export it smooth. Otherwise the faces are assumed to be split. Which is essentially what you’re doing when you flat shade a mesh, or use mark sharp. By default all meshes are created with flat shading. So just use the shading option on the toolshelf and change it to “smooth”. Then export.

If you actually wanted a low poly “faceted” look, then there’s no problem. The edges being marked as sharp doesn’t affect anything other than the shading.

i dont want my model to be smooth shading. however i dont want edges to marked sharp as well. people who are going to download my model might want to smooth if they want but they might not know how to clear sharp from imported model.

I’m not sure I understand the need to do that. Surely if you build a mesh with sharp edges you’re doing it for a specific reason.
Shading is an integral part of how a mesh looks. Why would you compromise just to accommodate something so specific?

How about exporting it as smooth, then when you bring it in you can just hit the flat shading option from the toolshelf? I’m sure they can manage to hit a single button without having a panic attack. :slight_smile:

no im not marking sharp myself! blender does it automatically when i export my models. which i dont want. in previous versions it didnt do that. before when i export something flat shaded it would import flat shaded without sharp edges. i guess i have to download a previous version?

This may seem like an obvious question. But I’ll ask it anyway. Why would you give someone an editable file in obj, if you intend them to open it in Blender? Why not just give them the blend file? :slight_smile:

Edges marked as sharp won’t show up like that in another application.

he will open it in 3ds max. doesnt use blender.

Ok. So why are you worried about the edges being marked as sharp? That’s something they can deal with in max using smoothing groups. They won’t see any “marked” edges. Just a flat shaded model.

Marked edges are internal to Blender. They’re a visual aid.

LOL. whatever u say i give up! lets say i would be relieved if i could export flat shaded model without edges being marked sharp.
i guess that wont be happening. whatever. thx for the replies.

you could take the export addon from the old blender and put it in the new blender under a different name. it requires some work arounds, like only have one enabled at a time usually, but not too bad. i use the obj exporter from 2.73 (maybe older?) since the new one doesnt play nice with sketchup 8, and no problems, even in 2.78.

Or just download 2.73. It just seems like a lot of effort for something that’s purely visual. He didn’t mention it causing any problems for the end user. And most people aren’t likely to be using older versions. So they’ll still see the marked edges.

Hmm. If you don’t want to export normals, why do you have “Write Normals” checked? :eyebrowlift:

And here’s the tooltip for this checkbox:

Thank you! that what i was looking for. its checked for default for some reason.