Sheep Slayer - It works! - Final Build pg 2

I’m working on a new game, Sheep Slayer. No sheeps are actually killed in this game, just knocked out(jus makin that clear) until you press the revive button. There are only two sheep so far. I intend to add more. There’s only 1217 poly’s in the game so far. I’ll probably make a shop where you can get different weapons later on.

Sheep Slayer

[EDIT]Woops. I forgot:

Arrow keys move around
Space bar swings sword
A key is the action button

[EDIT AGAIN] And 1,2,and3 change camera views.

To revive the sheep, go to the Revive button near the fence and press A.

Fun game, you should change the attacking animation so it can actually hit a sheep easier :wink: I love the poping noise when you hit the sheep, it goes well with the hit. The textures on the sheep could be better too.

Instead of the deer hunter series, it could be the sheep slaying series :smiley:

More sheep!! :smiley:
Nice game so far but I walked though the fence once and fell off the edge.

Ohh noo. I had a whole big long post typed, but I previewed it, then pressed back and it was gone. Ugh! Anyway I made a few changes. You unlock weapons by knocking out sheep. There are 3 weapons so far. You’ll hear a noise after you unlock a weapon. Cycle weapons when available using 1,2, and 3. Change camera views with F1, F2, and F3. Arrow keys still move, Space bar still attacks, A is still the action button. Here’s the blend file(no runtime this time):

[EDIT]By the way, thanks everybody. I’ll look into fixing that whole walking-through-the-fence-and-falling-off-the-cliff problem.

I’m using my friend’s computer, and for some reason, when I save a runtime, the runtime goes really slow. It doesn’t go slow in Blender itself. His computer is a little messed up anyways. I’ll have to post another blend file. Hopefully the runtime will work on my computer. I have made 2 cutscenes for the game, no menu yet. But the cutscene explains why you are attacking sheep. I have to warn you, I made this at 4:00 in the morning, so it’s a little out there.

Very funny, reminds me of my pooland demo from a long time ago :slight_smile: Killing sheep never gets old, hahaha.

Now I really have a problem. I’m back on my computer and I saved a runtime and the game still goes slow. Could somebody please take a look at the blend file and tell me what I can do to fix it? Why would the runtime go slow, but not the blend file itself? Thanks.

Someone please help. This is driving me insane. I’m on the verge of giving up. I have tried everything, but the runtime still goes slow. Not the menu or the cutscenes, but the game. I went through and took care of all the python errors that were popping up, and it works fine, error-free in blender. But when I run the runtime, it acts as if there is a python error. It moves sooo slow, and the weapons don’t appear, like the events aren’t occuring, but they are, or they were in Blender. I know I have a lot of logic bricks assigned to the empty, but I tried deleting them and it didn’t speed up the runtime at all. I’ve included the runtime and the blend file in this zip file :

I would be so greatful if someone would, out of the kindness of their heart, take a look at these files and possibly help me find a solution. Thank you so much.

Well, the problem is the Python isn’t working at all in the runtime. I have both files files that I need in the directory along with the runtime. The game works all except for the python. I saved a backup and narrowed it down to the basics. Not even the basic python commands were working in the runtime, but the worked in blender. Ugh! I don’t know what to do.

Well, I took a look at the file, in the exe, you cant see the character’s weapon.

It could be that exe just can’t handle it, while .blend can, but I’m no expert so I don’t really know, I’m just guessing.

My only suggestion so far is to continue the game on .blend, just because it runs slow on a exe doesn’t mean you shouldn’t continue, if you have a friend that wants to play, make him download blender :smiley:

The reason the weapon doesn’t show is because I use python to tell it which weapon to show, and Python isn’t working at all. THats the reason it’s running slow. I deleted all the python scripts and tried the runtime and it ran completely smooth. This isn’t cool. Everyone told me to learn Python because you can do so much more. I finally learn it and it makes it go slow. I guess I’ll just have to find a way around using python, which will be impossible. And I need the runtime, cuz I’m going to be putting it on my website, and nobody will download blender just to play the game.

Well, I’ve made progress. I’ve narrowed the source of the problem down to my whole entire computer. I started a completely new project and made python display the word “Happy” on a text face. Worked in blender, not in runtime, python23.dll and sdl.dll both in the directory. Could my python be out of date or something? Something’s wrong with python on my computer. Help!

[EDIT] I’m downloading the python installer now and will proceed to reinstall it.

I’m seriously at a loss for words. Why is python not working at all on my computer. I have python 2.3.5 installed, no error messages saying No Python Found, I have the path set to \Python23, which is the directory it’s installed to. It works perfectly fine, except for in the runtime. Here are the test files. It’s not even the game im working on, I’m just trying to get python to work. At least I know it’s not a problem with the game.

I have no idea what else I could do.

The cause:

import Blender

Remove it from all of your scripts. The ‘Blender’ module is not for game engine use. :slight_smile:

It’s still not really working. At least python is, though. Gracias big time for that. But now there’s a problem with importing

Can I say…

import gvar

…if I have a script named and I want to set it’s variables with another script, then say…



This is what I am doing, but for some reason it isn’t working. I tried running the runtime without importing gvar and it ran smoothly, but the problem is I need I guess if I spent some time thinking I could find a way around it, but is there something that I am doing wrong? Thanks.

Thanks to Lagan and Siegel, and a LOT of debugging, I now have the runtime for Sheep Slayer. Here it is, my first semi-finished game. Enjoy:

There are more weapons to come.

[EDIT] Woops. This is the right link:

The .zip only contains .dll files.

I know, it was an accident. I fixed it though. Thanks.

The sheep killing game is quite fun. I like to play games in Anaglyph setting, wearing the red and blue 3d glasses, it is a bit like moving around in a model set inthe Science or Natuaral history museum in London England!

Great fun, but the killing act is slow and the sheep have a tendancy to move out of the way when I am tryign to slice them up!

i am going to play with your blend though and see what I can learn.


Thanks bespoke. It’s been a while since I’ve worked on this, now I’m going back and adding more weapons and maybe more levels. I’m working on a bow and arrow and was wondering how I could make it shoot and have another one be created in the same spot the other one was. I’m not sure how to approach this. If I parent the arrow to the bow, I could easily make the arrow shoot, then have another one be created back on the bow and ready to be shot. But there’s one problem. If I turn, the arrow turns with the bow, which is dumb. So how can I avoid this problem. Once I do this I’ll use it as a formula for other guns, just like I did with the melee weapons. So, thanks i advance. Once I make all the weapons, I’ll start workin on the weapons.