Shift-C to center cursor (at world origin), model vanishes?

I think I might have a variant on this problem:

I have a .blend file of a humanoid whose feet are basically at the origin. I want to recenter the cursor at the origin, so I press Shift-C while in top/side/front view. Doing so makes all of the viewports center on the cursor icon, but the human is nowhere to be found. I can select it, and the vert/face/etc. counts are still accurate. I can’t tell if I’m in the object, or far from it, but zooming forward and back seems to get me nowhere.

Any thoughts?

Blender 2.4, of course.

Use Shft-S to snap the Cursor to Selected and press C (not Shft-C)


Sorry, I think you misunderstood. :slight_smile: I want to move the Cursor to exactly 0,0,0 (origin of the world), not the origin of the model. Shift-C is supposed to do this, yes? When I use Shift-C, I see the Cursor, but everything else vanishes.

Yeah, but you don’t say why. And you don’t say what view you’re in and where your model is (how many units away from 0,0,0)


I don’t know why Shift-C does this. I said I was in a Top/front/side view (i.e. I tried each of them) and it happens. And the model’s feet are symmetrically on either side of the origin.

Maybe this can help clarify what I mean?

Also, in the right shot, note that the grid is gone. Pressing 5 on the numpad doesn’t seem to change that either - it’s like I’m really far away or really zoomed into the grid. :frowning:

I don’t know why it does this. (I didn’t even know about the ‘shift c’ trick) Another option would be to put the cursor as close to the origin as you can, and use ‘shift s’ to snap cursor to grid. This will put the cursor exactly on the origin; 0,0,0. That way you can avoid the shift c thing. Hope this helps.

Mmm, very true. Good enough for me. :wink:

Although if anyone knows about why Shift-C is doing this, I’m all ears.

Yes, that’s much clearer. What’s happening is wrong. You should still be able to find your model by zooming out.


I keep getting the exact same problem…

It zooms out to the max, as far as I am aware, there is no solution to it but to reload a previous save where the bug hadn’t happened yet and re-do all ur work :frowning:

If anyone else can shed some light on this, please do

Shift-C does two things. It puts the 3D Cursor at the origin and, it adjusts the viewport so that all items in your scene are visible. So, maybe you have something very far from the origin (or your model is VERY large) and the viewport is adjusted to encompass that object causing the “disappearance” of your model.

Press Numpad-Del(or Dot) to move to a local view of the selected object (the 3D Cursor will remain where it is).

same problem here 13 years later in 2.79.
soloution found, close the 3d view and drag another one open to fix.
its not the far away object kermond its some glitch that never got patched.