Shift Camera background during render

I have a camera background image sequence. I use a ShiftX and ShiftY of background in camera settings. It works well in viewport, but my shift not applied when i use final render.
How to fix it?

Camera background images are just used for reference. They are designed to not be rendered. You’ll need to import the video as an image plane to get it to show up in the render(shift + a > Image > Images as planes).

Sorry but I would absolutely not advice to do that ^^ It would increase render time totaly uselessly, as video should simply be added in posted prod…
Image plane are usefull when it’s to be in the 3D scene (like a television) and not background for camera

You should make sure you checked the transparent param in render settings :
Screenshot%20from%202019-09-24%2014-14-39
And then use this kind of node setting in order to add video behind render :

See you :slight_smile: ++
Tricotou

1 Like

You are right. Compositing it in would be faster.