Shift Numpad 0 not working

watching Greybeard’s subdiv tut, i piced up on this Shift Numpad 0 comination to position the camera and decided to give it a test. However it never worked :-?

What could be wrong here?

Do you have numlock on?
Are you already in the camera view?

Yeah numlock is on and i hit 5 to go into perspective mode, adjust to get the view i want then hit shift numpad 0 but nothing happens.

I can’t get this to work either. According to GreyBeard’s subsurf tut position the object in perspective mode and then hit Shift + 0. I have tried the keyboard and numpad zeros with the Shift and neither of these work. I mean nothing happens at all and I do have num lock on. At least in the tut you could see something happen and it worked most of the time. Using windows 2000. Too bad cause it is a great way to position the camera quickly.

I really like this tut though!


There was some discussion about this on #blendercoders the other day. Win2k is swallowing this particular keypress, iirc.

AFAIK it doesn’t work on any windoze but you can get to it from the View >> Align View menu.


Wow, that’s sooo cool!

(Works for me!) :slight_smile:


To clarify – in my tutorial I don’t have numlock on and shift numpad 0 works 95% of the time (i believe there is a bug). In a previous tutorial I used shift-numpad-7 to switch to bottom view and several users couldn’t do this either (both linux and windows). Fortunately you can also use the ctrl key to get the opposite views ie. ctrl-numpad-1 for back view. Ctrl-numpad-0 is a different function unfortunately.

** deleted stuff that was wrong :expressionless: **

I don’t believe this is an operating system related issue as much as it is a keyboard related issue. With some keyboards not sending particular key combinations. Blender is the only application that I have ever used that has used these key combinations.


When numlock is on, Num4 is a ‘4’ and Shift+Num4 is the left arrow, the same applies for all the other numpad buttons - so when you press Shift+Num0 you’re actually pressing Insert…

I don’t know if this is a O/S issue or a BIOS issue - whichever handles the numlock, probably.