Shine ray tracing sun through sky dome?

I am trying to set up a scene with a sun shining through a sky dome and casting shadows.
Sun shines through sky dome OK with no ray tracing enabled.
But with ray tracing enabled sun won’t shine through sky dome even if dome is set as Transparent in Object panel.
If I set sky dome alpha to 0 in Materials and set the ground to TransparentShadows then sun still shines through dome and shadows are drawn. But I can’t see the sky anymore.
Any ideas on how to get this working?

Top left: No ray tracing enabled
Top right: Ray tracing enabled
Botttom left: Sky alpha 0, no TransShadows for ground
Bottom right: Sky alpha 0, TransparentShadows enabled for ground

Attachments





One idea is to render the skydome in a second renderlayer and composite it into the scene.

Another idea is to use an AngMap using the image as the texture of the sky in the world settings.

Tun off “traceable” on the skydome material.

Attachments


Thanks for the tips… Pappy’s suggestion seems to have worked!

Attachments


Although with the sky dome now not traceable it is not reflecting in the windows…

Attachments


Then you should try setting the texture to the sky/world, like suggested before.

Gotcha! Cyborg Dragon’s second suggestion of using an image texture for the World and angular mapping has worked. Thanks also MadMesh and pappy.
Here’s a quick Vimeo tute that helped me: http://www.vimeo.com/1526074

Attachments