Shortcut R for rotating does something else

I dont know why but when im trying to rotate an object with R key, it adds keyframes instead of rotating.

Any solutions?

It should only add a keyframe if you’re hovering your cursor over timeline area. If it’s also somehow does it even being in 3D viewport - that’s kinda strange thing I might say.

Anyway, have you tried to reset your Blender settings to default ones?

You could also change your button that stands for adding a keyframe through keymap options. See here for more info.

If you have Auto Keying enabled and Rotations locked, this happens:

Check if your rotations are locked, maybe

i fixed it by reseting it to deafults, still dont know how it happended, anyways thanks

1 Like

You’re welcome

More likely that your keymap settings were changed.