should this happen with alpha over?

Hi, I’m trying to do something simple, but I can’t make it work

I need a render layer to be alphaovered over another layer, but I obtain some artifacts around the objects in the layer, I can improve by pressing the convertPremul button, but they are still there

you can see in the attached images that there is one with the premul activated and the other one deactivated, both of them have the artifacts, altought the one with the premul activated looks a lot better, but still has it

I put the visors for showing you the alpha channels in both images

How do I make an alpha over without these artifacts? I need the small circle to be completely merged on the other figure (both of them have the same material) to the point it can’t be seen


Maybe you’ve activated Sky in the RenderPanel?
If so, just use either the Premul Setting or
the Key Setting with the PremulButton active inthe AlphaOverNode.

If your blue dot is a texture with an alpha on the other side, it could be a similar problem in your Material and Texture Settings.
There is a Premul option in the ImagePanel of the TextureButtons for that purpose.


thanks for the reply

it worked, partially, it worked with a layer, but when I combine with another one the problem is there again, just in one of the two layers interacting with the blue dot

the blue dot is a circular mesh, not a plane with a texture


making some tweakings on the solution you gave me and the premul buttons on the alpha nodes I finally managed to get rid of the artifacts

thank you very much for your help!!!