Show axis in Viewport Display too big

Hi everybody,

I customized the units in Blender to my needs. Instead of working in meters, I adjusted the units in centimeters and the grid in 0.01 scale. Everything works fine … until now.

If I check the option “Show Axis” in Viewport Display in the Properties Panel the axis which are shown in the viewport are way too big. It’s still fitted in meters.

Can somebody help me to adjust the display size? Where can I find the correct settings? I guess it’s somewhere in the Preferences. Thanks!

Hi Welcome,

Is that what you’re talking about? (Blender 2.82)

I hope this screen makes it clear what I mean.

The actual transformation gizmo is fine.