Show textured is not showing material colors -why?

There might be something I’m overlooking, but don’t you think it’s kind of backwards that when you set the viewport shading to the most detailed option (which is “textured”) the material colors are shown as grayscale. I’m talking about objects that have materials assigned without any textures used.

For me it would make more sense if the “textured” option would also show the material colors for non-textured objects. Is there maybe some way to work around this thing?

How do you have your scene set up? When I set the viewport shading to textured (Alt-Z) the material color shows.