Shrinking lights and halos


(Mikeman) #1

Happy Friday, everyone,

I’ve got a new dilmena.

The scene: I have a picture of earth in space. My ship swoops in from above/behind the camera, banks up/left then down/right all the while shrinking in SCALE so as to appear it is flying down into earth’s atmosphere in the neighborhood of southern california.

To animate, I did the initial swoop until the ship was in the middle of the screen, then from there had the ship scale down to just about invisible at fram 180. It looks pretty good…

So then I wanted to append this file I got from Blenderwars called “glow.blend”. It is basically a curve with halo turned on and a spotlight pointing backwards for extra haze ( I got rid of extra lamps and stuff I didn’t want). – placed in the exhaust of the ship so it looks like a rocket/jet flame. Looks really good.

Now the problem-- the two engine glows are parented to the ship… the whole ship/glow shrink in size over time till you can’t see the ship… but the problem is the HALO and the SPOT stay the same size… so when the ship is supposes to be barely visible, what I have is a full-size glow and no ship.

So how do I get the halo/spot to “disappear” with the ship? So far the only option I’ve seen is to forego the scaling and instead actually MOVE the ship really really far from the camera… but that gets to be a pain to zoom way out and in to manipulate things.

Ideas?

Thanks,


(djphotoduck) #2

I went and played around with the glow.blend file from blender wars. I think what you need to do is reduce the power of the glow as the ship shrinks. To do this:

-set the halosize in the materials button at the starting value for whatever frame you need
-hit the ‘i’ key within the materials settings window
-choose to set a ‘HaSize’ key
-go to the end frame (when the ship is small) and set the halosize to 0.00
-press the ‘i’ key and set a ‘HaSize’ key

This should take care of the halo. As for the glare from the spot light that gives the glare, animate the spotlight energy similar to above

Within the lamp settings:
-Set a key for the lamp energy at the begginning ‘i’ key and choose energy
-move to the end frame
-reduce the lamp energy to 0.0
-set a key - ‘i’ key choose energy

That should get rid of the lens flare

Hope that helps.


(S68) #3

YOu can also try to reduce size/alpha of the halo

Stefano


(VelikM) #4

To control the halo’s use the materials IPO window, HaloSize, Alpha work well to reduce the intensity/size, you can add both with the ‘i’ key with the curser in the materials window.


(Mikeman) #5

:smiley:

Worked beautifully - I didn’t know you could set keyframes in the materials/lights windows. Now I’m redoing other animations I’ve done with the technique! Thanks again!