shutter glasses on "DLP 3D READY" projector

Hi all!

Did anyone try to get a shutter glasses working on blender? I’m interested in this technology that many projectors are supporting today, is called: DLP 3D READY (http://www.dlp.com/projector/dlp-innovations/3d-ready.aspx)

I don’t know how set up blender to work and sync the stereo thing… did anyone try?

Thanks so much!

PD: is this the right place to ask?

I have tested it some time ago. DLP projectors with DLP shutter glasses work with Blender and 2.49b and 2.5x.

  1. Enable 3D Mode in the DLP projector.
  2. Set the VGA Display mode (VGA Driver) to 120Hz.
  3. In Blender enable under Stereo the Quad Buffer mode.


Attachments



Hey thanks so much!
just one question more… which graphics card did you use? does it have to be nvidia quardo? or it will run with a smaller one too?
BTW i can’t see the images…

Thanks for your reply! this saves me a lot of time and effort!

I have tested it with my laptop (QuadroFX 3700 1024 MB), but the Quad Buffer mode should run with any graphic card. The only thing that the graphics card must support is the max projector resolution at 120Hz.

Thanks so much again!

I have been trying in my setup but no luck for me. My setup is described below… I will keep on fighting and reporting so that anyone else can save time. Some more questions to everyone:
Is the connection type involved on the trick? HDMI, DVI, VGA…
Other settings in Blender that could interfere? fullscreen, GLSL vs Multitexture…
Does it have been tested under Win Mac and Linux?

None of this setups has worked …
A:--------------------------
MacBook Pro Intel Core 2 Duo 2,8GHz
Nvidia GeForce 9600M GT
Mac OSX 10.6.7
Blender 2.57b
Projector Viewsonic Pro8500

B:--------------------------
MacBook Pro Intel Core 2 Duo 2,8GHz
Nvidia GeForce 9600M GT
Windows 7 64 bit
Blender 2.57b
Projector Viewsonic Pro8500

C:--------------------------
Intel Core Quad Q9000 2.50GHz
Nvidia GeForce GTX 470
Windows 7 32 bit
Blender 2.57b
Projector Viewsonic Pro8500

Normally the quad buffer runs only in fullscreen with the Blenderplayer.

My system:
Dell Precision M6400
QuadroFX 3700 1024 MB
Windows XP 32 bit
Blender 2.49b
Blender 2.53 -2.57
Projector Acer P5390W
Connected to VGA
Blenderplayer fullscreen mode

Thnks again,

It was important to know that it has to run in the blenderPlayer and in fullscreen. Still not succeeded yet. I tried now in mac and win with the blenderplayer, fullscreen, and several resolutions and 60 or 120 pfs… all combinations, nothing. But starting to have the strong believe that is because of the graphics card. I think I will need a Nvidia Quadro to get it working. here there is some good explanations:

http://forums.developer.nvidia.com/index.php?showtopic=5885&st=0&gopid=18408&

I have currently borrowed someone my projector. If I get the projector back, I test it with a standard graphic card.

Thank you so much!

I could have access to an Nvidia Quadro FX 570 card and it is working under this setup:

Intel Core Quad Q9000 2.50GHz
Nvidia Quadro FX 570
Windows 7 32 bit
Blender 2.57b
Projector Viewsonic Pro8500 (no special settings needed, don’t even mind about the refresh rate, the app will change it)

It will only work through commandline and with blenderplayer (not working with runtime apps for me!). Use this syntax in Blender folder:
C:\Blender>blenderplayer.exe -f 1024 768 32 120 -s hwpageflip YOURFILE.blend

And make sure to enable 3D in Nvidia settings:
Nvidia control panel> Manage 3D settings> Stereo - Enable = ON

Hope that helps somebody in the future!
Jordi

Here are two links that describe how to activate page flip (quard buffer) on standart Nvidia card.
http://www.stereophotography.com/java/browsers/showpageflip.html
http://stereo.jpn.org/eng/stvmkr/index.html