sIBL GUI for blender doesn't work in Blender 2.78 RC

(Pengyu) #1

guys, I’ve been using sIBL GUI for months,the importer add-on for blender worked perfect with 2.77a ,
but does’t really work in 2.78 RC, basically blennder itself will close right after I hit the ‘Export button’ in the sIBL GUI
sometimes it will work,but most cases it is just like get triggered and close.

so I wonder if any of you guys encountered same problem or it is just on my machine. and any chance solve the problem? :slight_smile:

(the3dgm) #2

Not just your machine. I have the 2.78 Final release and it wont work with sIBL either. Looks like it’s back to 2.77a

(oyster_sauce) #3

confirming this with blender 2.78 release, sibl gui 4.0.8 and the usual script from
I have the feeling (and no better way to evaluate these crashes) that the problem comes from the script. I’m going to try to contact the author and ask :slight_smile: I’ll let you know.

(jedfrechette) #4

Please file a bug report with the crash details on the bug report page linked from the SIBL addon page:

I’'m not using it much these days so the addon has not been updated for the API changes introduced by 2.78 (or 2.77 for that matter). I’ll try to take a look when I have time, but for now I’m afraid Blender versions after 2.76 should be considered unsupported.

(Harvester) #5

Thank you Jed for looking into this and hopefully finding time to fix it for the new 2.78 API. I use sIBL with your add-on in Blender from a long time and I like it very much.

(Harvester) #6

I do have some interesting news.

My previous post was related to testing the sIBL add-on version 0.4 and sIBL GUI 4.0.8 on Blender 2.78a 64bit official release. Then, just for curiosity because I tend not to use development builds but only the official ones, I tried the add-on with a recent development build, Blender 2.78.4 dated 2016-12-19 [Hash: bd42987] and … it works perfectly! I don’t know what the developers did but I am now able to export any of the sIBL’s setups to Blender flawlessly, one after another, while before with Blender’s official version I had to delete all the rigs and images in Blender before being able to export a new one from sIBL GUI.

Perhaps I’m only lucky and with the next development build it will stop working properly again, therefore I cross my fingers. Could someone else test it too? Thanks.

(Harvester) #7

I’ve just got a new laptop with Windows 10 Pro 64bit (it’s an ASUS G752VS), and testing the latest 64bit build (Hash: 3d243eb) the sIBL add-on and related sIBL GUI 4.0.8 behaves now erratically: sometimes it works but usually when I push the button “Send To Software” Blender closes/crashes returning an EXCEPTION_ACCESS_VIOLATION error message in the debug console window.
On the other hand, on the other laptop with Windows 7 Pro 64 bit, this same build works perfectly, I mean no errors and I can change sIBL environments setup one after another from the sIBL GUI application as per my previous post. So, now I am a little bit confused. Does anybody has any suggestions or ideas? Cheers.

(csimeon) #8

I suspect it is a more general issue. I cannot confirm the specific but note :
Google “blender 2.78 crashes on linking” and you will find several issues and bug reports. I had such issues, i couldn’t transfer data between files, even cut and paste crashed.
I switched to 2.78b (for linux in my case) and all is good.

(sirdavid32) #9

Did this get solved? I´m on 2.79, and desperatedly need sIBL on Blender.

(colkai) #10

I am using Sibl GUI 4.0 with Blender 2.78C and it works for me first time around, but if I change the SiBL scene, it has to be done manually, otherwise I get errors or Blender crashes. (Windows 8.1 64-bit) It crashes 2.79 consistently if I try to use it at all.

(Harvester) #11

To me, the last version of Blender this add-on works with is 2.76. I wish to know python programming to help fixing this issue because sIBL is really a good solution not only to use HDR images inside Blender but also to manage third parties HDRi and edit them.

(colkai) #12

Yeah, admittedly, it would be nice to have this working in newer versions. :slight_smile: I usually just drop back a couple of versions to set it up then load the file in the latest version. Likewise the Lightwave Object Importer works better in Blender 2.75 so that versions sits on my PC for conversions of my old assets. If both plugins worked in 2.79 it would be easier.

(czerw) #13

Hey, did you guys found a fix for this? One beside swapping blender versions. It is an amazing program, such a shame the script was forgotten.

(macalister) #14

Yeah it’s a pitty that the script importer for Blender is not at the same level than the scripts for other programs.

Even the features are not the same, for example compared to the version for Maya, it lacks the sphere with the environment as texture visible only for the viewport, which is very useful as a guide for tweaking the position and size of the lights. It is specially useful in complex scenes where you have to reconstruct part of the original environment to effect the lighting.
Instead of that there is an empty with a spherical shape, but it misses that functionality.

I wish to know python just to add this feature.