SimbiontBlender 0.4

Yesterday I rewrote SimbiontBlender. The new version has a number of changes:

  • colour tweak preview
  • much more flexible mapping of DarkTree output to Blender texture
  • ability to remove active DarkTrees
  • the script now communicates directly with the plugin dll, removing the need to ‘Update’ your texture before rendering
  • opened DarkTrees are saved in a config file in the .blend

http://img217.echo.cx/img217/7384/diffuseandspecular5pc.jpg

The updated tutorial is in the usual place:
http://ten-ninjas.com/SimbiontBlender/

If you have trouble understanding the new channel mapping the tutorial is the first place to look.

The 0.4 version installer is here:
http://ten-ninjas.com/SimbiontBlender/SimbiontBlender_latest.exe
(You nolonger need to download any dlls separately, this should install everything you need).

Edit: source available here:
http://ten-ninjas.com/SimbiontBlender/SimbiontBlender_latest.zip

Let me know if you have any issues.

Enjoy!

Great to see that you haven’t been discouraged. :slight_smile: Will try it out, but it’ll have to wait til tomorrow (it’s 3.25am here and I’m about to get my beautysleep:)

Excellent work, thank you very much! :smiley: [!]

Tiggs

Hi, I’ve installed the plugin, but when I try to run the python script it says that it can’t find the MSVCP71.dll. What am I doing wrong?

Have you got a full python install in there and added to your path?

Loving this plugin btw :slight_smile: Easy and good results. Good work.

Thanks, script is looking better and better. Very professional.

One problem. When I ran the script I was getting errors of the nature of “module not found SimbiontblenderDll” or something. In line 20 you have a hard coded path of ‘Blender\.blender\scripts’ and my path is ‘my_test\.blender\scripts’. After adding the custom path everything seems to be working fine. Hope it helps. :slight_smile:

It ran fine for me the first time I tried it (although I haven’t figured it out yet), but the subsequent times that I have tried to run it when opening Blender I am getting the following error:

Using Python version 2.3
Traceback (most recent call last):
File “<string>”, line 659, in ?
File “<string>”, line 88, in init
File “<string>”, line 100, in loadConfig
File “<string>”, line 612, in parse
AttributeError: ‘module’ object has no attribute ‘search’

Any thoughts? Thanks.

Probably nothing. I’ve included msvcp71.dll in the distribution, this should fix your problem.

Let me know if you still have problems.
http://ten-ninjas.com/SimbiontBlender/SimbiontBlender_latest.exe

Ha! I didn’t think anyone would have an install directory not called Blender. New version should be good.
It would be useful to me if you could test the newest version for this problem.

It’s complaining that the regular expression module doesn’t have a function called search. I would guess you are trying to use SimbiontBlender without a full python2.3 install.

Let me know if this is not the case.

(It wouldn’t have needed to parse any config files on the first start-up since there was no configuration saved yet).

I’m sorry my english is not amazingly good, so when you say the dll is included it means that I should do what?

thx.

Sorry. The error you have is because blender cannot find a required dll. (a code library file).

The new version of SimbiontBlender should fix your problem. Download it from here:
http://ten-ninjas.com/SimbiontBlender/SimbiontBlender_latest.exe

Hope that helps. :slight_smile:

Thanks for the quick reply, but unfortunately it’s still the same problem.

Do you have any plans for a Linux version?

I am also interested in a Linux version. I am not sure what language you are using for the plugin ( The gui might be python, but somewhere I heard that texture plugins are in c ). If you are planning on doing a linux version, you should check out Winelib. This plugin looks interesting and very useful, but I can’t try it yet ( I might have to run Blender in wine %| ).
Good Luck

Ok. Had a go at it. Tried it out with some of the textures dowloadable on the darksim website. First, there’s still the problem that the first texture you load tend to fail. Sometimes I get 4 red crosses in the material preview. Also, when I try to change the ‘seed’-parameter, it just changes to 1, and then I can’t chose anything but 1 or 0. It also seems to work best on planar surfaces. I tried it on a rounded cube, and get a lot of stretching. I generally suck at mapping and stuff though, so I might be missing something else :slight_smile: All in all, though, this is definitely a step in the right direction. :slight_smile:

Yes, my integer tweak widget is broken, as noted on the website. Can’t find the problem.

4 red crosses indicate a problem with the DTE. Look at the console for interesting messages.

Try using different mapping techniques. I have happily mapped a skybox to the inside of a sphere using “original coordinates” mapping. You may have to stretch coordinates.

Blender sees the texture the same way a bitmap is seen? Seams and LSCM. :slight_smile:

I have a question. The new interface is getting to be very limited. The plugin setting in blender only has 10 ID levels and one object can use like 3 ID’s so that means if there are a couple dozen objects using the shaders there needs to be, I don’t know, a lot more levels? Since the bump and spec are inluded that helps, but still, at best only 10 colors of the same material. This is very bad. :frowning:

BTW just found the planet shader. It rules. :smiley: