Simple animation question...

Alright, I’m ready to pull my hair out here. Here’s what I’ve done…

I’ve parented an airplane to a path - it follows and tracks the path exactely as I want it to. Now, I’d like to animate the propeller. I went to frame 1, inserted a KP, went to frame 15 inserted another, went to the IPO editor and extrolpated it so that it spins forever. However, as soon as the plane changes course, the propeller does crazy things. The propeller is parented to the plane.

What am I missing here? What’s the best way to get the propeller to spin and follow the airplane as it loops and dives?

Thanks for you help!


I’ve had this problem before. To fix this, go to the IPO editor and delete all of the axes of rotation that are not being used. (e.g. they’re a straight line on the x axis.) There should only be one that is not a straight line (the one you extrapolated.)

hope that helps :smiley:

Was the propellor a seperate object parented to the plane prior to parenting the plane to the path?

It seems to work ok here:
(no comments on my 2 minute modelling job :wink: )

When you add the second keyframe (I assume that’s what you refer to as KP), it’s best for a rotation, to make it 90 degrees instead of the entire 360 degrees all at one go, as this will usually cause problems (and since you’re extrapolating it doesn’t matter anyway). By the way, if you open up a number dialog [n] in the IPO window, you may notice that the value in the text box for rotation parameters is 1/10 the actual degrees value. This is simply to make the curves in the IPO window scaled in a similiar range, so that they can be more easily viewed with the other curves that you may be using (location ipo curves for example).

That should work for you. In some cases you can also use an Empty to create a hierarchy so things rotate properly as was done in this blend file:

You could also try a search for the video tutorials by GreyBeard… He does a good job of explaining it in more detail.

I appreciate the replies. Thanks for posting the files Gimble. I duplicated what you had done in a new Blend file just to be sure I understood the way it is supposed to work. I think what I should have done, was to animate the plane itself, i.e., get the propellers working, prior to actually animating the plane through space.

Is there any way to animate the propeller at this point? What’s happening is that in order for the rotation to work correctly, the propeller needs to rotate along all three axes in order for it not to spin end over end. If it is just animated on the X axis, it animates fine until the plane turns or goes up or down at which point the propeller seems to be tumbling. Am I too late to animate it now?



You should be able to correct it.

Did you have rotations on the airplane prior to parenting the propellor?
This could be propagating down the Parent/Child relationship to the propellor.
I would try the following (on a copy of your blend file - keep a backup copy, just in case):

Clear the parent relationship between the airplane and the path using Alt_p.
Check if there is any existing rotation on the airplane by using the [n] Number function.
Clear any rotations on the propellor and airplane using Alt_r.
You may need to re-align the vertices in edit mode if the propellor/airplane are out of alignment.
Then do an Apply size/rotation Ctrl_a on the airplane and propellor.

If you prefer you could now animate the propellor first (though I’ve animated the propellor after the airplane was parented to the path with no problems).
Finally, re-parent the airplane to the path.
You may need to adjust how the airplane tracks the path using the ‘Track/Up’ controls in the Object buttons window [F7], Animation settings panel.

Other than that, I’m not sure what else might be causing the problem.
Are you putting any additional rotations on the airplane for aerial acrobatics? If that doesn’t help, maybe you could post the file (or a simplified version) and I could provide a step-by-step list to follow to correct it.

I tried another test by adding the propellor in a side view, but it still didn’t cause any problems: