Simple Asset Manager 2.8

What seems to be happening is that for some reason your code interprets the user request as a link rather than an append.
I can think of two schematics that could produce this fault, having taken a quick look at your code:

  1. The “append” interface button calls the link function or
  2. Something in the way the file is searched for and located in the library triggers the wrong if / else.

A third and less likely, in my opinion, is that the actual format of the file causes the problem. If this third is not true, you won’t find your answer looking at a file where the library append failed.
I suspect you can’t reproduce the error, because your code fault is about the library file and the path (case 2 above), rather than the file where they are appended. To make sure I’m sending both:

  1. A file from my library (a Chocofur free asset), pre-existing in 2.79 format
    put this file in your library under “Furniture” category, “Chair” sub-category
    Chocofur_Free_18_Fabrics.blend (737.8 KB)

    and
  2. The destination file, Blender 2.8, where I tried to append it. I left the chair as a linked object (no transforms possible until you make it local)
    DestinationFile.blend (919.5 KB)

The built-in Blender method is to make the object local (rather than linked) and there is a command just for that, as I mentioned previously.

I hope this helps

yep it is a liitle more complicated. I use the same thing except in last moment im assiginig a command to action parameter. and it when it is “linked” the bpy.ops.wm.link is assigned to action otherwise bpy.ops.wm.append. Thanks I will check that later :slight_smile:

[EDIT] I’ve done quick test, and indeed it appends as “linked”. Amazing. :smiley: Even more interesting is when i open the chair file and save it (without any modifications) then it when I want to import it again it appends properly. :O. Fast thinking: Might it be something with old blend version save?

that is the code responsible for import The buttons in UI differs mostly that one have parameter link=True :

action = bpy.ops.wm.link if link else bpy.ops.wm.append
action(directory=blendFile + "/Scene/", files=scenes)

All you need to do now is fix it… haha. Seriously though, it’s a nice piece of code. My days-of-old in programming, helped me follow your work and suspect where the problem is, but unfortunately I am not proficient in Python and the Blender functions to be of any specific help fixing it.

I think that’s likely, I thought it odd that the error didn’t happen with you and then thought you are probably testing with new models, probably all in 2.80. The destination file in all cases would be 2.8 format so I thought it unlikely you would get results if I shared that file only. That’s why I pointed out that the model is 2.79… and sent that along as well. But then why does the version affect the value of “link” and make link=true instead of false?

action = bpy.ops.wm.link if link else bpy.ops.wm.append

Looking forward for the fix, it’s a very useful addon!

Hi, I have a problem with HDRI previews. They are really strange, overexposed

and they aren’t similar to videotutorial. I put hdr files in the folder and I used the ‘render key’ of the addon to render previews. In addition, .exr files are not recognized such as 'Vp hdri skydome in the image.
How can I fix the problem?

I tried to install without unzipping on the latest Blender 2.80 beta version.
What went wrong? Below is the console message with the installation
failing.

Traceback (most recent call last):
File “D:\Program Files\Blender Foundation\Blender 2.80 Beta\2.80\scripts\startup\bl_operators\userpref.py”, line 605, in execute
module_filesystem_remove(path_addons, f)
NameError: name ‘module_filesystem_remove’ is not defined

location: :-1

I ran into this error as well earlier when installing any addon from .zip. It looks like this bug has been recently fixed, so perhaps it will work correctly in the next 2.80 version: https://developer.blender.org/T61455

1 Like

@Tibicen, I quickly went through the entire thread but didn’t find anything on such issue: each time I append an asset, the addon creates a new collection named with a file name + .XXX suffix. Is that by design? Or I do something wrong preparing asset files?
SAMcollections

Yes, I assumed that once it is added to the scene you can add by SHIFT+A and add collection.
But will have to think about it, maybe it is better if the name is the same add a instance of it :thinking:. Then if you modify the asset and want to append it once again you will only need to rename it.
You are probably right. I’ll add it to the list.

Could there be an option to append without creating a new collection? Or simply put all instances into the same collection? Keeping my screenshot above as an example, all ‘Cube.XXX’ instances would be placed in ‘Cube 1’ collection.
I just started playing with you addon, but it seems very handy tool :slight_smile:

I think I got even better idea. It could work this way: appended asset could be selected as an active object, and then you could just invoke the ‘Move to collection’ modal launched normally by the ‘M’ shortcut, so user could decide each time where to put it.

Hey there. For some reason I’m getting traceback errors when I used the latest build @Tibicen

I am getting the traceback errors too @Tibicen

how do I know when its done rendering the thumbnails. I tell it to start rendering the thumbnails, and a separate blender window opens, but i go back and try, and it leaves some un-rendered

thanks
TIM

Hi! I don’t know since when happens, but with today’s blender build (26-02-2019) and SAM 0.9.4 when I render the thumbnails there’s an object that appears in every thumbnail.
See how the model “Campana 90 cc0” appears in several thumbnails:

It appears in every thumbnail, even in other folders/categories.

This is a great addon and I can’t thank you enough but… I got to ask :slight_smile: any chance we can get categories for materials? Or maybe several_materials>1blend instead of present 1material>1blend

Hi, Tibicen!
Fantastic addon. Really appreciate the work you’ve put in.
Is it possible to allow users to adjust the amount of rows/columns in the asset grid?


I have a lot of FBX files and scrolling through them can become difficult very quickly.

Back from holidays,
@SecretTomodachi I will take a look at it this on the weekend.
@Botoni can’t really copy the issue. but will take closer look.
@nafergo will take a look at material categories, but due to “my” ideology it is better to have materials separated into files. So when modifing and (for instance) uploading to cloud it would only upload small blend file insead of big one.
@Alex_S I remember there was an option for that in the api, i will try to put it in settings. You are right it even looks annoying. :slight_smile:

Excellent. Thanks a lot!

Not sure if this is a Simple Asset Manager problem or a Blender 2.8 problem or a Tim is dense problem

When I import a file (append) for some reason, only part of it appears at the cursor, the rest appears at the 0,0,0 origin – im using simple asset manager and I’m in version 2.8 – any ideas whats going on?

Thanks
TIM

Does this add-on support individual node groups? Or only full materials?