Simple Programming not Working

I’m just starting to do some programming in Blender 2.49b. I wanted to try using the logic bricks first. I tried to control the default cube in game with the arrow keys (without using physics). If I add one control (ex. Arrow Up to move up along the z axis), it works fine. But as soon as I add a second command to go down when pressing the down key, the game doesn’t function. When I press P, the window only shows the default blue background and nothing else. What am I doing wrong?

That sounds odd. If you could post a screenshot, that would help.

Alright, here ya go:

With only one or two sensors activated, the game works fine. As soon as I add a third one, the cube doesn’t show up and the game doesn’t work. Blender does not crash, but the game will not work right.

I just had a thought: Do you think it might have something to do with the version of Python I have installed? I’m using 2.6.2

I don’t think it’s a problem with Python, but nothing there shows up as odd to me… Try changing the Physics settings (Change Static to Dynamic), or try deleting certain bricks.

Changing the physics does nothing. If I put the third set of bricks in, the game malfunctions as usual. I then deleted the third set of bricks, and it still didn’t work without it. Once the game stops working once, it won’t work again unless you restart Blender, even if you delete the set of bricks that originally caused the malfunction.

I’m sorry to ask, but it’d be a great help if you could send us the .blend :slight_smile:

Sorry I haven’t responded lately, but here’s the .blend file.

BGE Error.blend (128 KB)

I still don’t get what’s up with this, though. Sometimes I’ll open the file and it will work, and sometimes is just doesn’t.

I noticed that if I’m just modeling a character (or a similar mesh) and press P, the same thing happens. I also firgured out that once the game fails once, I can’t get it to work until I close and reopen the file. Hope the file helps explain something.

I just installed the 2.5 beta hoping it would work, but it still does the same thing. Does anyone know what the heck is wrong?

I think it’s your build.
it works fine for me.
anything temperamental or simple is normally human error or build fail.
what i recommend you do is find any traces of blender, in PROGRAMFILES, APPDATA (or application data in XP)
mentioning “blender foundation”.
Then install fresh copy of blender 2.49b and if it asks you if you want to use previous data, say no,

Do you mean I should completley uninstall both 2.49b and 2.5? I also saw on the Blender website that if you uninstall 2.5, you should create backups of all of your production files, so I’ll have to move those temporarily to a USB drive. Does the term ‘production files’ also refer to textures and sounds, or is it just meshes/scripts?

basically, anything “YOU’VE” added to blender, backup, then uninstall all traces of blender from program files and app data

Thanks a lot, agoose77, it worked! The game engine works normally, now. I would have been screwed if I couldn’t get Blender to work properly, so thanks again!

no worries. those little bugs can be realllllllly annoying!

Bad news, I think it’s still doing it. I have to add more stuff for it to happen, but it’s starting to periodically fail again…do I have to go through this whole process again?