Simple scene cube falls "up"

I took the default opening scene (cube, camera and lamp) and added a plane. I set the cube and the plane to be rigid bodies with collision enabled. I didn’t touch a single other thing. When I play the animation, the cube flies UP instead of falling down. I checked the scene settings, and gravity was set to normal default. As I said, this has never happened before, but with this latest installation of Blender, this was the first time using any physics like this. I am using 2.77a. When I say “default”, ALL things as are they were when I did a new install, so there are no weird things that I have changed. The ONLY thing I changed is to select Cycles render instead of Blender Render. Nothing else.

Please ALWAYS supply an example .blend file that illustrates the issue with any support question.
And no “But it’s the default scene!”, please. If it was, the cube would not behave that way.

If the Cube falls up then there are a few ways to fix that… as for the cause of the issue? could be a number of things maybe?

To “Work around” your problem you could just rotate everything or even simpler, go to your scene tab then where it says gravity, just remove the Minus in the Z axis column making it (9.81) and it will fly in the opposite direction… I know this doesn’t actually fix the problem but I hope its a solution for you!

How can I “supply a blend file”? I did notice that if I add one or more additional cubes to the scene, they all fly apart from each other, as if they are repelling each other. I tried reversing the Z gravity, but the cube still flies off into the air.

This is one file that is giving me several problems. What I want is for the cube to fall, and collide with the cylinder inner wall and come to rest inside the cylinder. One problem is that it ignores the cylinder collision but it does collide with the plane and come to rest. Another problem is that the cylinder’s presence causes the cube to “fall” in the Z direction a little, even though I set Z gravity to zero. And I did that in order to avoid rotating the cylinder, which I thought might be causing issues. It’s a mess. If I remove the cylinder, everything is fine. The cube falls and collides with the plane, end eventually comes to rest. But even then it seems to rotate and bounce for a long time. I tried changing some settings (friction, bounciness, etc.) but only changing the mass seemed to have a little effect. It still bounces too much, so something else is wrong.
NeedHelp.blend (606 KB)

Not sure if this is what your trying to achieve and I’m definitely not to qualified to be giving advice. I played with your blend file a little. Try changing the rigid body collisions on your cylinder, shape=mesh and source=final.

AFWS - It does work when I changed what you suggested. But I don’t understand why it works or what those settings mean, or what they do, etc. The Blender manual doesn’t really explain WHY this would work, and why my original settings did NOT work. But thank you!

Hi

Maybe I can help You a little…See picture:)

First viewport show what I see when I open Your blendfile…View is right vp. Turned a little so You can see the groundplane…If You don’t have the very bassic right…It for sure god bad.

Select it and rotate it 90 degree move it up to the cylinder select the Cube move it up a little.

Next viewport is Cameraview.

When I play simulation the Cube go left…It’s because…In the Gravity box y is set to - 43.07 set it 0

When i play simulation now the box stop on top of cylinder I don’t no why…Remove passive from it fix it…But that’s not the right solution.

There is a few other thing I so…Bassic and important.

View 3 : the cylinder fill the grid…You should try to stay inside the Grid with Your model…I have turn Metric on in Unit.
Groundplane is 1.3 Km…It mean You can’t see the hole plane in You viewport…Unless You change the Clip end.

A Cube have 8 verties hmm think it’s vertex…You have Subdived it 5 times…!!! It make it to 6.144 vertex…This is very very BAD.

Always try to make it so simple You can don’t use more than You need…Your computer Burn…:slight_smile:
It is a lot easier to work that way…And You can always increase it.

Ohhh I almost forgot…See picture…Plane is selcted it should have a scale 1 it do not have 1 it’s 0.679…!!!

Most modifier use scale 1 to calculate the result…So if it is not 1 the result will be wrong…In object mode select object Press Ctrl + a to reset Scale to 1…Puff Puff.

Hope this can help a little…Damn why is it so hard to edit a post…grrrr

Tai

Attachments


Tai, thank you for all your effort. I will try these changes and see what happens.