Simple UV image/vertex paint question

Hi everyone,
I wonder if anyone can help me with this simple problem:

I have a mesh ( it’s a cube subdivided a couple of times)
I used ‘Vertex Paint’ mode to make all the faces the same colour.
I have a painted image UV mapped to a single face, and I want the mesh’s vertex paint to show through when rendered.
It works OK using ‘Texface’ in the materials panel, but I can’t get it to work correctly using the Texture/ Map Input/ Map To settings.
The image maps OK, but the parts where the Vertex paint should show through are white.

Can anyone tell me how to do this?


Use the color slider to lower the amount that the image blends with the texture or click the alpha button in the map to pannel and enable the use alpha button in the texture buttons.

Thanks. I’ve got it to work now, using the alpha buttons.