Simplest traffic light

I am trying to create an animation of a simplest traffic light with radiousity (Emit). However I can’t insert a key that would capture the radiousity. “I” for RGB doesn’t work. Could anybody help please? How do I animate a change in radiousity?


Place you mouse over the materials menu and select All Color. Then in the IPO window simply select all curves except Emit and delete them.

There is also a radiosity tutorial on the wiki:

I did as you said and nothing appeared in the IPO window. I’ve also rendered the whole video and radiousity wasn’t changing in it. Please see attached and tell me what I am doing wrong.

There was nothing about locking and then changing the Emit functions in an animation.


traffic1.blend (158 KB)

Sorry, I failed to make myself understood. I try again.

  1. Press F5 to open the material’s menu.
  2. The I key (I like in Igor) is context sensitive. So, with your object selected, place your cursor in the material’s menu and press the I key. In the menu that appears you should find “All Color”.
  3. In your IPO curve editor, there is an “IPO type” drop down box. By default it is displaying “Object”. Change it to “Material”. Now you should see a large number of curves in various colours.
  4. Select all curve with A key. Deselect the orange Emit curve by RMB it. Delete all other curves with X key. Now you should have an IPO curve for the Emit value of your material.

In your file there is an IPO curve for Emit for the red material. It has 3 keys inserted and its value changes from two to zero between frame 25 and 37.

Edit: In your file you need to enable “Radiosity” in the Scene menu (F10).

Mats, I’ve done exactly as you said and then rendered the whole thing but radiousity didn’t change in the video. Please see attached. What am I doing wrong?

Video is 60 frames. The idea is: video starts with red light on, then on 25 frame the red light starts to fade, and on 37 frame it is completely off.


traffic2.blend (155 KB)

Unclick the “shadeless” button on your red traffic light.

After a closer look, this scene isn’t really set up for radiosity properly at all for the effect I think you want.

  1. Traffic emitter lights shouldn’t go all the way through the blue block.
  2. Subdivide your blue block by about 12.
  3. Change your blue material so that it isn’t 100% blue and 0% Red/Green.
  4. Unselect “shadeless” from all your materials.
  5. Your emit value for your red light is too high for the ambient settings on other materials.

But really you shouldn’t be using your lamp at all if you want accurate radiosity. If you render out this attached file I think you’re getting closer to the effect you’re after.


traffic3.blend (238 KB)

It did the trick! Thank you very much for fixing it!!

Could you also please help me in my other thread: