single surface renders with lines on it. How to fix it?


First of all this is my first post to the community and I hereby want to say that it’s nice to meet you.

To the problem then. In the edit mode the surface is made out of a single ngon. But when rendered it appears consisting of several polygons and the seams between polygons show up in a nasty way.

I have a strong feeling that this has something to do with Bmesh. But I have no clue how to fix this.

Even if this surface is made out of several polygons why do the seams show up like this? If a plane is made of several polygons it still should look like a smooth surface, shouldn’t it?

Please see the attached image.

Any help is greatly appreciated. Cheers

I don’t see an image, retry attaching it, also are you rendering it in cycles or blender internal? Another thing, having the vertices on the ngon not being even might cause this. But we need to see the screenshot.

Oh… no idea what happened to the image. But now it’s there. Hope it helps.

I use Cycles. I am totally astonished by it. Truly a great piece of coding.


Oh wow. That is strange. Do you have any sort of shader set up? If not I have no idea what is happening.

This either happens when the mesh is too close to the camera or the object is too small.

This has happened to me many times in Cycles, and shouldn’t with the above observations of DCBloodHound. Perhaps there will be a fix for this at some point in time. I find this happens quite a bit on transparent surfaces.

All I have is just the object and a white diffuse shader. The length of the object is around .5 BU. There is also a subsurface modifier.

I think I solved the mystery. Increasing the size helped, but did not hide the seams. decreasing subsurface iterations also helped and removing subsurf altogether fixed the problem.

Anyway the biggest find was simply that the seams got visible only in real time render. On full render (F12) the seams disappeared.

I think this is pretty much solved. But one final question. Is that a bug or a feature of Cylces real time rendering?

It’s a result of using the orthographic camera. If you switch to perspective camera it should go away.

try to report it as a bug and see what answer you get !