Sketchup Model Is Imported But... Wierd Model Issue and Noob Camera Q

A fairly experienced Sketchup but Blender noob user here. I’ve imported my Sketchup model into Blender via Alex Vaq’s non-plugin Google Earth unzip method. It’s in. But I’m having some issue that maybe some folks - even folks who don’t mess with Sketchup - may know something about:

  1. The model is displaying funky. When you move around to view the model certain “planes” or slices of info seem to not display then display when you continue moving. Very odd.

  2. When I add a camera (since it doesnt default with one) it doesnt seem to be a standard camera. There is no camera icon and I’m having trouble moving it around.

I’ve seen on one site to use f9 to edit camera settings but f9 just messes with Mac os display (even w/ fn + f9).

Having some troubles with this unfriendly, opaque, many-things-hidden-behind-cryptic-hot-keys, force-me-to-research-how-to-do-the-simplest-of-tasks business. But I want to learn. I have a history of professional software use so I’m not completely ignorant!

Please help. Much appreciated.

Almost all features in Blender can be accessed by using menus or onscreen controls. However, most people find hot keys quicker to use and as such they are the features you see used most often.

Hard to tell what the issue is with the flashing planes, without a screenshot. One thing to try is in Edit mode (press Tab or change the Object mode drop-down to Edit mode), select all (press A or from the Select menu choose Select all) and then press Ctrl-N ( or from the Mesh menu / Normals choose Recalculate outside).

For your camera, make sure you added the camera by select the Add menu (or press space bar) then Camera. This must be down while you are in Object mode and not Edit mode. Once the Camera object it added, select it and then press Ctrl-Numpad 0 (or choose Set active object as camera from the View / Camera menu).

One finally note, once you have your camera selected, use the following button to choose the Edit controls:


Great. Thanks a lot DM. I’ll try these suggestions out.

Did you try to export from sketchup as *.obj and import it to blender. If you have flashing plains it means that they might be doubbled (face directy under face) this might be one of the reasons for for artifacts while rotating and moving camera. Try remove doubles. In edit mode (f9) pres “A” then press “W” and select “remove doubles”. What also could be the reason, you may have two models sitting on each other.

Hey, sblender! A hearty welcome to the good ol’ Blender steep learning curve! Take, heart! The rewards are well worth the few destroyed keyboards you’ll likely go thru (after bashing them into an unrecognizable mash of platic and wires out of sheer frustration.) Speaking of keyboards, go hereto find a good hotkey layout bitmap link. Your other “most used favorite” will become the wiki manual. Look about for the tutorial links listed there, too.

Yeah, what andromeda said about removing double verts is pretty much SOP for any imported geometry. You’ll also want to routinely re-align your normals to face “outward” (which I think is ctrl-N… not sure) as you import and edit mesh geometry. Look around for a button in the mesh edit panel that will turn on normal display indicators (and allow you to change their “length” so they can be seen.)

Best of luck on your fresh, bright-eyed blenderbliss™ adventure! :smiley:

Thanks everyone for the suggestions.

I’ve tried:

  1. reversing the normals
  2. recalculating the normals
  3. removing doubles

I also mocked up a super simple Sketchup model to make sure it wasn’t related to any complexities in the model… here’s a screenshot…

BTW, I have borrowed a friend’s Blender book and am reading up on this app - and am excited to get into it. Thanks for the welcome!

Attachments


I remember stumbling over something about converting Sketchup’s 3 sided geometry to 4 sided geometry - i tried that in a previous test and didn’t seem to change the result – and am not sure how / where to find that option now…

re: andromeda23’s q about how i exported from Sketchup: that bold text is a link (links are hard to see here i know) which explains the way its done.

  1. Using the free Sketchup, export as Google Earth 4
  2. Kmz format (Google Earth 4) is in truth a compressed file with the 3D model format “Collada” inside, textures and other information. have to use a trick to uncompress the files then:
  3. using blender import using collada 1.4

There is no option (in free version anyway) to export as a .obj file.

One thing I noticed from your picture is that the 3D grid is super tiny (i.e. your model is WAY to big). Try scaling it down with S (or Object>Transform>Scale). If you don’t want to do this a thousand times, you can type a number after pressing S (a number like 0.01 might be good. :D)

Next, to get the 3D cursor (little red target thing) back were it should be, press Shift C, and then C to recenter the view on the cursor.

Lastly, to fix the rotation of the model, press Alt R (or Object>Clear/Apply>Clear Rotation) to clear rotation.

sblender, I guess I’m not sure I understand what your problem is exactly. The geometry in your screenie looked okay to me - just appeared to have one vert pushed out or somesuch. It was triangulated, which is okay if you’re not planning to subsurf at all. But there’s a convert-to-quads function built in to the menu, now (spacebar -> Edit -> Faces -> Convert to Quads [alt-j] (see attached)) Which should clean up a lot for you in this regard.

If you’re worried about the geometry being “transparent” (or not properly occluded) during edit mode, this can be turned off via a little button on the view panel’s header (which only displays if the panel is in shaded mode (z-key toggles)) - see attached #2.

Not sure if this is what you’re wondering about, tho…

Attachments



Break thru!

  1. It was a scaling issue I think. The size of the model must have surpassed blender’s limits and was being “cut” where the model extended past the limits. I reduced the size severely and it seems to working fine.

  2. Related to this: Sketchup models are set to specific, real world dimensions. How do I keep the dimensions intact for various models I would import so that they stay in proportion with each other? Does blender allow for real world dimensions - or are all measurements just “blender units”?

  3. I’m still having trouble with cameras: I can’t rotate beyond just 1 axis - severely limiting my options. How do you rotate on other axis? (Perhaps I can figure this out with some investigation…)

  4. How do you delete objects? It seems so odd to have to ask such a basic question like that - but there’s nothing in the interface - and nothing in the glossary of my blender book for removing or deleting objects.

Thanks everyone! Baby steps perhaps - but it feels like progress!

Hmmm… I don’t think there are such limits to scale within blender. I would rather think what you’re experiencing has to do with clipping planes. Each camera and viewport (in the UI) has front and back clipping planes that are set specifically by default. Any geometry that is closer than the near clipping plane will not display (in a viewport) or render (by a camera.) Likewise for any that is beyond the far clipping plane. Check into the settings of each to adjust them.

There are just “blender units”. There’s been a bunch of “whining” about this alleged shortcoming, but the reality is: every 3D (or 2D) application only just uses “units”. They’re just numbers to identify coordinates. The difference is that many CAD-related apps have a little “translator” component that takes these raw numbers and makes them appear relatable by a human user. Blender simply lacks this lil’ ol’ translator, so you gotta do it yourself.

Cameras behave just like any other object - they can be moved, rotated and scaled (altho this last one only affects their iconic representation, AFAIK). The trick to making cameras effective, IMO, is to set each up with a “track to” constraint pointing at an empty. Then you can manipulate the empty all you want to allow perfect camera control. For animations, cameras (and their corresponding empties) can be parented to curve paths for smooth motion.

X-key (or delete, too, I think). The thing to remember is the object oriented nature of blender. An object is just an entity that points to a mesh. Thus many objects can point to, or use, the same mesh object. When this mesh is altered, all the objects that are linked to it change, too. And etc. This is what the “outliner” panel attempts to illustrate: all the links and relationships between the objects in your scene. When you delete an object (in “object mode” as opposed to “edit mode”) the object which points to the mesh is deleted, not the underlying mesh object. It merely becomes unreferenced (as long as no other objects are linked to it.) All unreferenced entities are by default deleted when a file is closed. There is a setting that you can click to make these be “kept”, tho. This is also true for materials, textures and other things, which are each just other blender objects. (e.g. when you apply a material to a mesh, you’re merely creating a link between these two objects.) Confused yet? :smiley:

ha - thanks much mzungu. will dive into this further… and will def. try the camera approach you suggest. thanks.

A question though: are all rotates only around a single axis? Is there a way to rotate on other axes? It only seems to rotate in one lopsided way?

Thanks.

Rotation is relative to the viewing angle. Try using 7, 1, and 3 on the keypad (not the same effect as above your keys) and then rotating. You can also use the hand manipulator, that red green blue thing in the 3D view, to rotate, grab, and scale on the specific axis. Also, you can press the axis you wish to manipulate by (z x and y keys) to effect only that axis (eg. Rotate X rotates on the x axis no matter what the angle). Last! If you’re manipulating an object and you move it mostly on the x axis clicking the mouse wheel will lock it into that axis. Last again, holding shift and pressing a key will not manipulate that axis.

And you should probably read the Blender n00b to Pro wikibook because that explanation was quite terrible.

… in addition to what Iconoclast said, hitting the x, y or z key twice (e.g. xx) will shift the rotation axis to the local object’s x axis as opposed to the global x axis.