Sketchup to blender help!!!

i have created a model city on google sketchup that i would like to import to blender to add detail and game programming. can i import the file to blender 2.48a? and how?

Ha, good question. but it’s easy. Go to file>export (i remember, it has been a while ago :wink: )and then kmz Google Earth 4 (google earth). and save. now go to that file in your file browser. It will be called something like: myfile.kmz. here’s the trick: rename it to! now unpack it.
Now go to blender and import a DEA (collada 1.4). now go to myfile>models>myfile.dea, where you unpackt it. TADA! Not working?

Hi Everybody. I have done this steps. I have also installed Python 2.6 and I got this message on Blender’s Console:

I go to System Menu, generate the report and It is supose to create a text file, wich I cant find. I’m stuck in this step. Can you help me? Thanks.

You need python 2.5

Oh. Ok. :slight_smile:

i couldnt figure it out. later, i found out i had to go to file>export>3d model>.kmz>save
u were pretty close tho.

ok i still cant get it to rename. i renamed it .zip and it still says its a .kmz so what should i do?

EDIT: should i download an older version of sketchup? would someone plz help!

ok so i found out it renames if i rename it through winrar but when import it to blender it takes a few seconds and then doesnt show up. i got blender to recognize it as a .dae but it still wont import. can somebody please help?

oh and sorry for the triple post

ok first srry for the quaduple post, but now i got it to import (was importing wrong .dae format) but now it only shows a bunch of empties everywhere. any help?

Its easier to export to google earth V3 and use the import script. It import it directly.

Right click on this next link and choose save target as:

If you click it with left button it will open as text.

Copy this file to your blender > Scripts.

And you have a new option in the menu Import > Google Earth 3

Hum. I’m not able to post links yet.

This link will open as a text file:

You can choose “View source code” In your browser.
Or right click the link and choose “save target as”:

Download it and install it on your Blender > Scripts

You now have a new option in the import menu.

Obviusly read any licence on the models or the programs.


Edit button FTW.
I always import my sketchup files as collada scenes.

But I follow the steps: Sketchup > GoobleEarth4 > Zip extension > Un zip
Python 2.54 installed >import Collada 1.4 and I got this error:

my problem was that only empties would appear. all parented to a empty in the center on the 3d view window.

ok i just noticed a status bar at the top of the blender buttons at the top of the screen. it says “creating Blender nodes” should i wait for this to finish? is this normal?

is it just that my pc is really slow and is taking a while for the file to import?

To be frank, this is not really a question for this sub-forum…which is probably why you have not gotten a good answer.

Try here: Python & Plugins

ok, but Dilopho DD has done it b4 and it worked so im waiting for them to reply