Sky Domes and AO

I am making this city, for a super hero anim, and I have to use a sky dome, because the ‘real’ setting for the world buttons, doesn’t respond to the cameras position in space, only it’s rotation. So I am using a sky dome, which is fine, except for it whacks out my AO settings, and if I turn off traceable, which fixes the AO problem, I don’t get the reflection of the sky dome in my windows. Also, I thought of, after making my ipo for the camera, moving it to a different layer, animating only the sky, and then loading that anim in the back buffer, when I shoot the scene. But that is the same problem, no reflections. So, I’m thinking, I can do that, and load the anim of just the sky in the world texture, set to, hm, paper? Not sure what to set it to, but anyway, does sanyone know of an easier way? Like is there a way I can turn off AO for that object, or is there a way to do it with nodes?

You’ll have to create multiple scenes or at least multiple renders. You need to make the sky in one scene and not the other (via Scene>Add New> Full Copy) then separate your AO and reflections passes via ctrl click (you get a litle black dot) on the render layer tab then click it normally to turn it gray (selected…sothat it renders as a separate element rather than with the rest of the scene or being excluded totally). You can select the bottom left corner arrows on the render layer nodes in the compositor to select which scene the layer comes from. Finally it’s up to you to figure out how you want to recombine AO from one scene and reflections from the other. You’ll probably be better off “Adding” reflections via a mix node and “Multiplying” AO via a mix node which is the proper way to do things but definitely not the only way. It really just depends on what you’re trying to achieve.

Rather than running on and on here’s a .blend for you to pick apart. You have a steep learning curve ahead of you.


thanks man. sounds complicated but I’ll give it a try.