Sky Image Shows Through When "Mist" Is Enabled

Hi, I am using an image for my sky but when I enable “Mist” the sky image is coming through the mesh in the render. Any ideas why and how to fix this? Using Blender 2.6.7.

Also can I color the mist?

Instead of Mist(world panel), use the Mist pass. In the compositor connect the mist pass to a color ramp then connect it to the factor socket of a mix node. connect the combined pass to the top socket of the mix node. Now you can change the intensity of the mist with the factor value. Connect an RGB input into the bottom socket of the mix node and change the color to whatever you want.

Thanks ldh1109,

Sorry but I don’t see a “Mist” node in the compositor. My scene will be animated and I want the distance to look misty or in fog. Can you post a sceenshot of the nodes.

enable mist in the properties panel under layers

http://www.pasteall.org/pic/show.php?id=26469

ldh1109. thanks for the explanation. I got it working but am disappointed it won’t let me use an image for my sky. I tried but there are two problems.

  1. The sky shows through the mesh. In other words the sky map is rendering on top of the geometry. Weird.
  2. The mist is so dense it won’t let the sky show through. I tried every setting imaginable but I couldn’t seem to make the mist semi-transparent so the sky would be visible through it.

I might have to post you a file to show you what I mean.

  1. The sky shows through the mesh. In other words the sky map is rendering on top of the geometry. Weird.

Thats weird. maybe disable the sky on your main layer and and have another layer rendering only sky

  1. The mist is so dense it won’t let the sky show through.

change the white in the color ramp to a grey to make the mist less dense

post the blend or a screenshot. I’ll see what I can do

Thanks again lldh1109, will do that. :slight_smile: