skydome not rendering

im trying to make a simple skydome and it shows up in the viewport but when i render it out its all grey. another thread said the image had to be assigned to a material and not just uv mapped to the sphere but i cant find any way to add a material to it. here is the blend file if anyone is able to help

Have you changed you cameras “clipping” distance. You may have change the clipping distance for your viewport, but you also have to set it for your camera.

What do you mean you don’t find any way to add a material? You’ve already found a way to add 3 materials to the ground and grass, with textures.

There were no textures included in the file so don’t know what it will look like but here are the settings for basic UV mapped material texture: