Slow Blender interface (cause: OSX ?)

Recently I installed blender 2.35 on my iMac G4 20" witch OS 10.3.6 on it.
For some reason the interface is really slow.
Modelling the 3D object and navigating in 3D space is ok, but if I click on any option on one of the panels or menus I have to be patient.
The option gets selected after a second or so instead of instantly.

Back in the days I owned a PC (which is recently) the interface was much faster. I tried Blender 2.32 on my mac. Though not as fast as my PC, this still is a lot faster than 2.35. I really want to use the new features. Is there anything to speed up the interface? What’s wrong ?

PS I did try to switch to thousands instead of millions of colors: it didn’t help.

I am running windows on a PC, and it works fine for me. however, one thing that really slows down my PC is using background pics. dose it run slow like this with just the default scene?

The default scene is slow already.

we had already a report on slow imac G4. it seems to be a driver problem.

try also to hide the dock. Do you use any other OpenGL app ?

Or any launcher, utility besides what is installed with Os X ?

In the system preferences one can alter size, magnification, position, minimize effect, the options ‘animate opening applications’ and ‘automatically hide and show the dock’.

I don’t think I can completely shut the dock down and to be honest, I don’t really want that.

if this is a driver issue, can something be done about it?
(like updating drivers or something like that)

hide it that’s all

10.3.6 has the latest graphic drivers i think.if you didn’t do tht already: switch to thousands of colors (display preferences), it helps me much on my G4.


Blender (2.35a) works better on my 17" G4 iMac OSX 10.3.6 than on my recent IBM laptop T42 (winXP). “B” selecting is jerky on the PC and it feels that the graphics card doesn’ t support the OpenGL very well. On the mac on the other hand everything work smooth (even with the dock visible and millions of colors). So I think it may be rather a conflict between apps. How much RAM have you installed? I have 768MB.

It’s the clock.
I had the analog clock floating on my desktop.
Now it’s gone everything is superbly fast.

Thanks guys.
The interference thought made me reconsider things like this.