Slow down for seemingly no reason

Whenever I bring up menus or hover over tools/options to select them, the program and my mouse cursor seem to slow down to sub 20fps. It works fine and is silky smooth whenever I do any other action such as sculpting or moving objects. It also slows down immediately after rotating the viewpoint. Help is appreciated.

Running Windows 10, GTX980Ti, i7-6700k, 16GB Ram

Hi, I would have to see it to properly diagnose it, but you could try this if you have not yet done it:

1.- I would check if you have the latest nvidia driver installed. I think the last one (For jedi fallen order) is particulary good. (Check if there is a studio driver available for you model, but I think that one is for the 10xx series and above)

2.- If you have a system has two display cards (Usually an Intel and a Nvidia), check on the Nvidia panel that you asign blender to use the nvidia GPU, because some times is using the intel one.

I hope this can help you.

For anyone having the same issue, I had to go into the nvidia control panel > manage 3d settings > program settings tab > blender

Under specify settings I had to change “monitor technology” to Fixed Refresh

Thanks Eduardo for helping me out

1 Like