slow internal blender

:frowning: I have a laptop with 512mb ram and a 1.8ghz cpu with 64mb ati igp 320m video card. The blender looks wonderful all fuctions work. Just a strange question, I have a simple set up:

default scene with cube replaced by a uv sphere and a plane below the sphere .
it is not really a problem just weird. When I render the scene with internel blender it takes about 7 seconds…pretty slow. but if I use the yafray render with skydome at low setting it smokes and renders at 1.2 seconds with high setting it barely beats the blender internal at 6.43 seconds.

My question is why is internel blender slower ? On all my desktops the internal blender is faster than yafray render ?

is there a setting that I am missing or is it in the opengl setting ?

Thanks in advance


on some systems blender takes an incredibly long time [like 5 seconds] to open or finnish drawing the render window

however, the system I remember doing this doesn’t have a problem when the proper drivers are installed and working [16 bit color mode too…]

the system I have in mind however isn’t a ati based one, but an intel based desktop.

you ought to get much faster render times rendering from the command line if that is the issue, no window is opened to be slow to draw to.

You can either:

(a) delete your .B.blend file (it’s in ~/.blender/ on linux, or either C:\Documents and Settings&lt;username>\Application Data\Blender Foundation\Blender.blender or <blender install folder>.blender on windows). This will reset your default scene to the builtin scene. However it will also reset all your personal settings, themes, etc.


(b) delete the sphere and the plane, add a cube, and press Ctrl+U to set that scene as your default.

ya some systems take a long time
for me yafray takes longer than blender internal

the system I have in mind however isn’t a ati based one

whats wrong with ati I have so much ati stuff and it all works perfectly with blender

the ati igp card is old

it kinda compares to the nvidia tnt, or is a bit older iirc