Slow Motion particles

hi

I have been following the blender guru tutorial on creating sparks using the particle info node to divide the particle age by the lifetime to produce a ratio - which in turn feeds into the material making the particles fade based on how old they are or how far away from the emitter they are. I then tried to recreate this “slo mo” effect and ran into some problems.

I used the time remap function on the render settings to remap the animation to slow it down and it had the desired effect on the particle motion - however it seems to be having an odd effect on the materials.

Without remapping the time value - the particles fade based on their age as expected - i.e. the particles fade the further away from the emitter they are - but do so consistently throughout the animation showing that each particle is aware of its age (these three screenshots are taken from frames 1, 20 and 40 of the animation respectively)




If I remap the time value to slow the animation by half (old time = 50, new time = 100) - I get the following output for frames 1, 20 and 40 (see next post)




I dont understand what is happening here. The first frame looks ok - but it appears that the output of the division calculation changes over the course of the animation meaning that by frame 40, all of the particles that are being emitted think they have already exceeded the lifetime and thus are applying the “faded” part of the material. Its almost as if the particle age information isn’t being passed to the particle info node if you apply time remapping and it therefore assumes all the particles emitted have an age based on the start of the animation, rather than the time each particle was actually emitted.

Can anyone suggest whether I am doing something wrong - or could this be a bug?

(Actually - this thread would probably sit better in the materials and textures section).

Another way to slow down particles is to lower the timestep parameter (under Physics rollout) in Newtonian or Fluid mode. This is how you can do Bullet Time style effects.

It does seem like a bug and you may be right. Particle age may not understand time remapping because it is external to the particle system.

I did try that - but all it seemed to do was to shorten the life of the particles. I’ll have another play with it.

Cheers

Edit: Yep - worked a treat once I upped the particle lifetime.

Here are a couple of example following the suggestion above

thankyou so much, you save my life. i don’t even know if this problem came from lifetime value