Slowing Done

Is it just my machine, or does Blender actually get slower the more complicated a rendering becomes?

Blender can put a strain on any processor depending on what you are doing. Sometimes you have to be creative, like if you are doing a scene with more than 3 or 4 big trees, you have to consider your options. If you give us an idea of what your scene is like, maybe we can come up with some suggestions.

Well, actually, I’m just rendering a female head. I got started on the eye and everything slowed down significantly. To the point where I have to wait almost a minute for whats on the screen to catch up with what I’ve done, even if I’ve only moved a single vertice. And it’s not like my laptop is becoming hot. I run it on a lap fan, so it’s actually quite cool while I work.

Rendering as in pressing f12 or having the preview window does become slow pretty quickly and depends on the speed of your processor, and it always re-renders everything if you make a change to something.
Just editing and working in the 3d view should not slow down unless you have very high polycounts, and it depends on how good your graphics card is.

That does sound unusually slow to me, especially if you weren’t experiencing it before. Polycount is a good thing to look at. I’ve had slowing in the past due to distortion animations on large objects (like an array along an animated curve) – anything moving in your scene? Is auto-key turned on?

Nope, nothing was moving. I think it was probably the polycount, since the eye was supposed to be pretty detailed (I was working on the iris at the time). However, it was a pretty old version of Blender, so that might have had something to do with it. I have just recently upgraded to the latest and greatest (recently as in five minutes before the time of this post), but when I tried to open the file, Blender stopped responding. So, even though I’ll lose a head I was very proud of because it was made of awesome (in my not-quite-so-humble opinion), I’m just abandoning that project and starting again. I’ll let you know if it starts to act up again. Thanks for the help!

St. Anonymous

how many vertices do you have ?
how many modifier are set ?

can you upload the file so we can look at it and do some testing!

happy 2.5

Well, when I went into the file (finally), I managed to delete the piece that I was working on. However, I found that I was unable to unhide the head I had spent so much time creating. I, um, actually got so frustrated that I deleted the file. I managed to salvage it from the trash, however! If you can unhide the head, I would be so happy-ecstatic!

human head.blend (336 KB)

~St. Anonymous~

When I open the file, it has 8,520,283 vertices. Bogs down my computer too. Blender 2.49 crashed when I tried to open it, 2.56 opened it. Turning the subsurf down to 1 for the object in the viewport, dropped the count to 1,142,283 and my computer isn’t bogged down anymore. Where you sculpting this that the count’s so high?

Anyhow, doesn’t matter. Alt-h to unhide the head. It was cranked up on the subsurf as well. After turning down that, I ended up with a 12,123 vertices. I think maybe instead of cranking the subsurf up so high to smooth out the mesh, you might want to hit ‘set smooth’ for smooth shading to make it appear smooth.



human head.blend (436 KB)

Oh, I forgot that I had done that. My bad! I’d only done it cause I was messing with the settings. Anyway, thanks! I thought I’d never get that back. You are made of awesome and I have learned the error of my ways. (Me, err? Never!)

I am forever grateful!
~St. Anonymous~

normally you don’t work with subsurf higher then 3

and with sculpt it may get very high poly count !

and all that may make blender sluggish for certain!

happy 2.5

Another setting is something like “Octree resolution.” Basically, this is the data-structure that Blender uses to quickly locate polygons and other objects by their location. It might be applicable in your case… not sure…