Smallluxgpu

Hi all,
Could anyone answer these questions for me…

  1. Should I be able to use smalllux on a standard laptop ?

  2. If so, is there any graphicall build with it installed, I have looked and can’t find one.

  3. Do I need to download it separately and link it to blender exporter.

  4. If so, where do I get it?

Many thanks…

Latest buids here:


Copy the included render_smallluxgpu.py in your 2.58/scripts/addons folder and acctivate in user preferences.

Cheers, mib.

Great… Thanks for that… Just one other thing… I got 2 messages when I tried it before.

  1. No opencldll found ( is this a big problem?)
  2. No light source detected…(does smalllux use blender light sources or am I missing something)?

Many thanks again…

  1. You need a OpenCL device, CPU or GPU, is almost included in the newest grafic driver.
  2. Only sun lamps or mesh emiter
  3. I send a test file with a mesh emitter and a environment image, it is set up for CPU only rendering.
    http://www.pasteall.org/blend/7366
    Change the path for SLG and so forth.
    You need a modern GFX Card from ATI or NVIDIA for GPU rendering.
    Cheers mib

What am I possibly missing here?

I have done the following:

  • downloaded the graphicall build link above
  • copied the .py to blender addons directory
  • enabled the addon in Blender
  • changed the path to SLG
  • set a folder for the export (I just used the SLG scenes folder)

set up a simple scene by adding a cube and a plane,… set materials, and made the plane emit in the material.

When I render I just get black, but no error that I can see,… there is no alpha either, so I don’t think it is just not lit. Tried the sample scene above, and get the same result.

Any help would be appreciated, Thanks.

Thank u mib, u have been very helpful.:slight_smile:

Hm, the new slg2 allows only gpu rendering, may your try the older 1.8.
http://www.luxrender.net/forum/viewtopic.php?f=34&t=5987
Try to run slg2 with the bat/sh files without blender to make shure slg2 works on your system.

Or go for the new cycles render for blender.

Cheers, mib

The SLG batch files run fine, but I’m just getting black inside of blender. Trying to figure out what I’m missing.

And yea, I’ve been using cycles, but still waiting for a new windows GPU build.

EDIT:
I don’t know what I did, but it just started working now. Wish I knew what I did different, but all is good at the moment.