Smart Fill Addon 1.4.0 - Blender 2.9.3

What happens when you hit the F key 2 or 3 times in a row?

1 Like

I can hit F as often as I want. No options in the window at all.

1 Like

For Blender’s default (n-gon based) fill this would be expected, but the other fill operations Smart Fill should be providing options. If Smart Fill can’t cycle through the other fill options when you hit F again (with no undo after first fill operation), I suspect there could either be something interfering with Smart Fill’s operation or something unique about the scene geometry that is causing the other fill operations to fail.

Were you using Blender’s default “fill” keybinding before installing Smart Fill (i.e.: F for “Make edge/face”)?

Also, can you provide a screenshot of the geometry you were trying to fill?

When I want to fill a circle and hit F key one time the circle is filled with cross lines and in the options tab, in ‘span’ option, there appears the number 1… when I put it to 0 the lines change to parallel. But there is no any way to fill the circle with a single empty face (as it happens with the native F command of Blender).

Thanks for sending a demo file. I was able to figure out why Smart Fill was not able to use the grid filling option. I forgot that Blender’s grid fill tool requires a closed loop with an even number of edges and faces to work on, but the loop in your test scene has an odd number of verts and edges (313). If you add an extra edge to the loop (Subdivide 2 parallel edges), grid fill should work as the vert and edge count would then be even (314):

smart_fill_fix

I am not sure Smart Fill has options you would be what you want to fill in the loop though. You might have to create some inner geometry inside the loop to get nicer looking results. Grid fill creates a lot of ugly looking triangles when there are concave edges in the loop you are trying to fill. You might be able to get okay-ish results if you use grid fill’s “Simple Blending” option and experiement with different Span and Offset settings:

smart_fill_fix_2

It should cycle between the normal n-gon fill and grid fill every time you press ‘F’ as long as the Smart Fill toolbar is still on screen:

smart_fill_cycle

Is this not working?

Thanks for the answer. Getting the edge count to an even number worked. However for my purposes it doesn’t do the job any better than Blender’s internal Grid Fill - it’s basically the same. I hoped, that the “smart” part of the addon would help me here, but it seems to be more helpful in other cases.

It should be the same or very similar, Grid Fill is what Smart Fill uses internally as one of its filling options. I do not think Smart Fill includes any “new” filling options, but it does do some minor modifications to existing fill operations.

For a the demo file you sent, one option worth considering is breaking up the long single face on the edge of the table into more geometry before trying to create a surface. Filling operations work better when there is a more even distribution of geometry in the loop you are trying to fill.

Newbie here,

I purchased this and followed the install process . However, I’m seeing the following results when trying to bridge two objects (I tried this in Bforartists and Blender - versions 2.81/2.82):

ezgif-7-3acb334861db

Can you provide any guidance?

Hi, I tried it in blender 2.81, it works well,
1 Ctrl+J to merge two objects
2 slect faces on the two objects, count the number of the faces
3 F merge, left corner menu can adjust the bridge
4 addon preferences can set Ctrl and Alt adjust bridge

Hi loveordie,

Thanks for the insight. Partially my fault but also it looks like Bforartists is not working with this addon. I’ll let them know. Thanks again!

I spoke to the Bforartist dev and he believes there is an issue with Smart Fill when used with Bforartists. Maybe the Smart Fill dev can take a look? I use Bfor because it has a better interface (but the underlying code is the same as Blender).

Here’s the (correctly) working Add-On in Blender with adjusted modifiers:

Now using the Add-On in Bforartists, you can see the modifiers do not work:

I didn’t have any issues with the modifiers with Bforartists bforartists2_alpha_080 for Windows. They worked when I tested it:

Did you mean the Smart Fill Mouse Scroll hotkeys? Those did not work by default, but I was able to get them working by changing their defaults in the Keymap Preferences:

1 Like

Cool cool, I’ll take a look and see if that resolves it. Thanks!

Yup still not working for me. I made sure my keymaps match what you have but it’s still failing, although, again in Blender it’s working fine for me.

I also tried using the Blender 2.8 keymaps in B4 and I also disabled addons I have added to bfor but still no love. I’ll see if the console turns anything up.

I ran b4 with debug mode on for handlers and several fails popped up when executing smart fill (i.e. pressing the F key after selecting the faces of two joined objects like the example I posted above). I’m not sure if this has any relevance:


wm_event_do_handlers: Handling event
wmEvent  type:1 / LEFTMOUSE, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(79,62), ascii:' ', utf8:'', keymap_idname:(null), pointer:000002655F534B08
wm_handlers_do_keymap_with_keymap_handler:   checking 'Screen Editing' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'View2D Buttons List' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking '3D View Tool: Select Box' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Edit Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint (Draw brush)' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint (Erase)' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint (Fill)' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Sculpt Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Face Mask' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Weight Paint Vertex Selection' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Pose' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Object Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Paint Curve' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Curve' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Image Paint' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Vertex Paint' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Weight Paint' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Sculpt' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Mesh' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Armature' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Metaball' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Lattice' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Particle' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Font' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Object Non-modal' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Frames' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking '3D View Generic' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking '3D View' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Window' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Screen' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Screen Editing' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'View2D Buttons List' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking '3D View Tool: Select Box' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Edit Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint (Draw brush)' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint (Erase)' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Paint (Fill)' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Grease Pencil Stroke Sculpt Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Face Mask' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Weight Paint Vertex Selection' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Pose' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Object Mode' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Paint Curve' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Curve' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Image Paint' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Vertex Paint' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Weight Paint' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Sculpt' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Mesh' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Armature' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Metaball' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Lattice' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Particle' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Font' ...fail
wm_handlers_do_keymap_with_keymap_handler:   checking 'Object Non-modal' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Frames' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking '3D View Generic' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking '3D View' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Window' ...pass
wm_handlers_do_keymap_with_keymap_handler:   checking 'Screen' ...pass

Thanks for the additional information. I’m still not sure what the problem is.

Just to clarify:

  1. Are both meshes in the scene you are trying to join with Smart Fill part of the same object?
  2. Is the full “Smart Fill” popup (with the Connect Loops, Merge, Merge Factor, Twist, etc options) showing up at all after you press ‘f’, just the “mini” one (with Span, Offset, Simple Blending), or nothing at all?
  3. If the popup panel is showing up, does manually adjusting the panel properties (by dragging or clicking directly inside the popup) do anything?

Also, can you attach a sample “.blend” file that Smart Fill fails on? If you don’t want to make the file public, you can send me the file in a PM.

I understand where you’re coming from. My first impression was that it is a user issue (many times, it is) but I execute these exact same steps in Blender and everything is fine. Here’s the blend file from B4 JUST after pressing the " f " key.

smart_fill_b4.blend (776.8 KB)

The post where I attached both the Blender and B4 results show the dialog that appears after pressing
" f ". In Blender, all the sliders work, but in B4, none of the sliders have any effect.

Thanks for the blend file. I’m still not able to recreate your issue though, at least not when testing that blend file with Smart Fill 1.3.2 in the Windows x64 build of 2 Alpha 0.8.0 build of Bforartists . :frowning:

The only other things I can think to try would be assigning Smart Fill to a different hotkey than " f " or try calling Smart Fill directly from Blender’s Search Bar (the Search Bar hotkey should be F3 by default in Bforartists) and see if either of those options work.

Example GIF of using the Search Bar I made when testing out your blend file:

smart_fill_sbar_t2

Confirmed, I’m using v1.3.2 of Smart Fill in Windows 10 X64

I finally got it to work but it’s rather strange,…after pressing " f ", I need to hold down the SHIFT key and then roll the mouse wheel down…Once I do that, THEN adjusting the settings in the Smart-Fill modal works. If I go directly to the modal after pressing " f ", none of the functions work. (See video below)

Great plugin, should be in Blender by default.
I’ve seen on your gumroad that you have more tools for Blender. Do you have plans to port them to 2.8?

That is weird. Could you send me a PM with your system-info.txt?
You generate the file in Bforartists by selecting:
Help > Save System Info

I think @jimpaw80 's plan was to port them all, but I am not sure what the status is on that. The only tools I know have already been ported to 2.8 (other than Smart Fill) are Smart Select and Smart Delete..