Smart Select - 1.4.4 This update fixes the install issue and select mouse problems

Weird, I still can’t make this bug show up. Do you and @Colacuve mind uploading the userpref.blend file being used when the error appears?

It will be in Blender’s executable directory if you created a “config” folder here:
blender-2.80-blah\2.80\config

Or at somewhere like this (if you’re on Windows 10)
C:\Users\USERNAME_HERE\AppData\Roaming\Blender Foundation\Blender\2.80\config

The location will be displayed in the console after you click “Save Preferences” in the Preferences window:
Writing userprefs: C:\Users\USERNAME_HERE\Path\To\blender-2.80-blah\2.80\config\userpref.blend' ok

Another option might be Exporting your Keymap settings. Blender will save them as a “.py” file.

The selecting behavior in Blender was rewritten with the move from Blender Internal to EEVEE and changed something. I’m aware of the issue, but haven’t found a solution yet.

1 Like

Sent you a private message. Thanks!

Hi JimPaw80 and nBurn . I’ve just installed the recent beta version. I’m running Blender 2.8 beta daily build from 02Feb2018 on Windows 10 (I update builds roughly every fortnite). I’m running on a 4k display, with 125% Windows Display Scaling, and 125% UI scaling inside Blender. I’m using Left select with new standard Blender hotkey map.

Initially, everything seemed to install and work as expected. So at least things are off to a good start. However, I soon confirmed that, I too, am experiencing the same issue reported by Colacuve . Alt-Clicking on a face seems to trigger a loop select that is far offset from where I’m clicking. However, when I move my mouse, it seems to select a different loop. That’s why I’m suspecting maybe the various windows display and UI scaling is part of the issue. However, I can’t really run a 27" 4k display without any upscaling, so hopefully this can be resolved (if, indeed, it’s at all connected).

Also, I will quickly add that loop select seems to work if I alt-left click directly on an edge (while in face, edge, or vertex select mode). It only makes strange selections when I alt-click more centrally on a face while in any of the selection modes. Vertex select mode seems to work most reliably, but I guess I’m usually clicking on a specific vertex in that mode.

Good luck! This tool is so useful when it’s in full working order! :slight_smile:

Man thanks for some stellar feedback!

Windows 10
image

I getting an error message if i trying to install the addon:
image

I also tested it with the current available build from https://builder.blender.org/download/ I still getting the error message.

Cheers!

Sounds like this is a bug in the current builds of Blender. You may have to unzip it manually.

I can’t seem to make this add on work while in wireframe mode, is there any fix for that?
I also wish you could click off the mesh while in solid mode (like you can for standard loop select)

I’m on 1.3.2 and blender 2.79b fwiw

apart from that I love the plugin, good job :+1:

Heyho,

it still breaks the toggle selection hotkey:


image

That is probably a new bug since they merged tweak and drag thresholds into one value. Addon has to be updated for current builds.

Just Purchased. Lots of cool potential. I can’t get loop and fill selections to work predictably though. It takes many attempts to get my actual intended selection. Often it’s selecting edges or faces on the backside or just other random loops. I’m trying this on pretty basic meshes like extruded cubes and cylinders. Unfortunately it’s not to the point where I could use it in production, but I’m happy to help work out the bugs. Love the Paint select.

Thanks for the feedback! Hopefully this can be fixed rather soon, anyone know when the fully official Blender 2.8 version are suppose to be released?

I don’t think any one can say exactly, but I’ve heard May-June timeframe several times.

Just an idea, but maybe if you could implement a way to selectively enable/disable features of the Smart Select suite in a modular fashion (through the Addons preferences panel), we could enable the features that are working for us while disabling the features that aren’t… it seems like bugfixing for 2.8 is something of a moving target. Smart Select’s Loop-Select features are currently an area with issues… personally, I could live with disabling them for a time. For me, the real every-day workflow killer features are mainly 1.) autofill of an area defined by manual “border” selections (where I select the outline and let Smart Select select all the geometry within) and 2.) “paint select”. Secondary (but still awesome) features include auto selection of coplanar surfaces (or defined by the surface derivation angle parameter) and auto selection using defined UV seams and “hard” edges, etc. Obviously, I like all the features of Smart Select, but I would be happy to just be getting on with a subset of those that are currently most stable in 2.8 beta.

I noticed this myself over the weekend when I used a newer 2.80 build to try to solve another Smart Select bug. One of the Blender devs made a large number of API changes over the last few days and that seems to have broken a lot of stuff. I didn’t have these errors in the 2.80 builds from a week ago. I plan on having a fix for this with the next Smart Select update.

I’m not sure this is fixable. The reason this doesn’t is Blender changes how selections work when in wireframe mode. For example, if you double click on a face in solid mode, the selection stays the same, but if you double click on a face in wireframe mode, Blender will check to see if another face is behind the current selected face and selects that one instead.

Yes, current selection handling is problematic, I’m still looking into a fix for this one. As for disabling features, that’s a possibility, but I’m currently prioritizing fixing broken features. Hopefully that will not require too much work, but if it does I could add a disable option as a workaround.

Any chance that the file I sent you via private message 8 days ago was helpful in tracking down the issue I’m running into? :slight_smile:

I looked into this a little over the weekend, but still could not recreate the bug. :frowning:
Even with using the custom preferences files, Smart Select wasn’t throwing any errors to the console when activated or during use. What I think that may be causing that error is a conflict with another add-on.

smart_select_1.4.0_beta_2 is out now, all buyers check your mailboxes!

Him jimpaw80 - I’ve just opened up the 1.4.0_beta_2 and am using today’s build (28Feb19) of Blender 2.8 beta. I’m still experiencing the same issues with loop selection that I (and others) described in my last post. I even manually disabled Windows Display Scaling for Blender on my 4k display to make sure that wasn’t the issue (it made no difference). Basically, unless my attempt loop selection is pixel-perfect, it will loop select a random loop far away from the one I was trying to select. Will try again on the next addon beta update - good luck cracking this tricky one :).

This update was just a quick fix for the tweak_threshold bug that showed up in recent builds. I’m still looking into the loop select issue, but I’ve not had much time to look into it this last week.

Seems like it is broken again because of an API change:

image

I getting it if I try to enable it.

image