Smart Select - 1.4.4 This update fixes the install issue and select mouse problems

Just Purchased. Lots of cool potential. I can’t get loop and fill selections to work predictably though. It takes many attempts to get my actual intended selection. Often it’s selecting edges or faces on the backside or just other random loops. I’m trying this on pretty basic meshes like extruded cubes and cylinders. Unfortunately it’s not to the point where I could use it in production, but I’m happy to help work out the bugs. Love the Paint select.

Thanks for the feedback! Hopefully this can be fixed rather soon, anyone know when the fully official Blender 2.8 version are suppose to be released?

I don’t think any one can say exactly, but I’ve heard May-June timeframe several times.

Just an idea, but maybe if you could implement a way to selectively enable/disable features of the Smart Select suite in a modular fashion (through the Addons preferences panel), we could enable the features that are working for us while disabling the features that aren’t… it seems like bugfixing for 2.8 is something of a moving target. Smart Select’s Loop-Select features are currently an area with issues… personally, I could live with disabling them for a time. For me, the real every-day workflow killer features are mainly 1.) autofill of an area defined by manual “border” selections (where I select the outline and let Smart Select select all the geometry within) and 2.) “paint select”. Secondary (but still awesome) features include auto selection of coplanar surfaces (or defined by the surface derivation angle parameter) and auto selection using defined UV seams and “hard” edges, etc. Obviously, I like all the features of Smart Select, but I would be happy to just be getting on with a subset of those that are currently most stable in 2.8 beta.

I noticed this myself over the weekend when I used a newer 2.80 build to try to solve another Smart Select bug. One of the Blender devs made a large number of API changes over the last few days and that seems to have broken a lot of stuff. I didn’t have these errors in the 2.80 builds from a week ago. I plan on having a fix for this with the next Smart Select update.

I’m not sure this is fixable. The reason this doesn’t is Blender changes how selections work when in wireframe mode. For example, if you double click on a face in solid mode, the selection stays the same, but if you double click on a face in wireframe mode, Blender will check to see if another face is behind the current selected face and selects that one instead.

Yes, current selection handling is problematic, I’m still looking into a fix for this one. As for disabling features, that’s a possibility, but I’m currently prioritizing fixing broken features. Hopefully that will not require too much work, but if it does I could add a disable option as a workaround.

Any chance that the file I sent you via private message 8 days ago was helpful in tracking down the issue I’m running into? :slight_smile:

I looked into this a little over the weekend, but still could not recreate the bug. :frowning:
Even with using the custom preferences files, Smart Select wasn’t throwing any errors to the console when activated or during use. What I think that may be causing that error is a conflict with another add-on.

smart_select_1.4.0_beta_2 is out now, all buyers check your mailboxes!

Him jimpaw80 - I’ve just opened up the 1.4.0_beta_2 and am using today’s build (28Feb19) of Blender 2.8 beta. I’m still experiencing the same issues with loop selection that I (and others) described in my last post. I even manually disabled Windows Display Scaling for Blender on my 4k display to make sure that wasn’t the issue (it made no difference). Basically, unless my attempt loop selection is pixel-perfect, it will loop select a random loop far away from the one I was trying to select. Will try again on the next addon beta update - good luck cracking this tricky one :).

This update was just a quick fix for the tweak_threshold bug that showed up in recent builds. I’m still looking into the loop select issue, but I’ve not had much time to look into it this last week.

Seems like it is broken again because of an API change:


I getting it if I try to enable it.


I think this might have been an issue isolated to the 47ba487e05da (736) build of 2.80, Buildbot was reporting compile problems with that release. I tried Smart Select with the b6d1946c2e6b (738) build released a few hours after 47ba487e05da and didn’t get that error.

Mh strange I updated my blender to the current recent build:

and still getting the same error if i try to enable it also tried out with factory reset but it still dosen’t work on my end.

Weird, I wonder is something is going on with Buildbot? I did some more checking and at least half of the recent Win 64 2.80 builds had compiler warnings in their logs, including 0bbff8a71138 (739). I will try to investigate this issue some more tomorrow.

I also have that Loop Select Bug in 2.8 described earlier in this thread.
I hope you get this fixed soon because for selecting this addon is really a must have! :slight_smile:

btw … is it supposed to happen that when I stroke from top to bottom in edge mode that vertical edges get selected too?

Would be cool to have the edge paint selection tool work as nicely as vertex and face mode.

Trying to selected the inner area of selected edges with alt and holding left mouse button but it doesn’t work. Neither double click to select an outer loop. 2.8

Also alt-lmb is supposed to drop the selection first … but if you alt-lmb on a selected element it behaves like a toggle which alt-shift-lmb should be, no?
It only drop the selection with alt-lmb when I click on an unselected element first.

If I delete faces and then select the edges of the created hole with alt-lmb and then hit alt-lmb again the hole gets closed … but it only works directly after creating the hole.
Is this a feature or a bug and is there some kind of documentation where all features are explained? :slight_smile:

Was this with the “Load Factory Settings” option or something else? I looked into this over the weekend and wasn’t able to recreate it, but I run a “sandboxed” version of 2.80 (by creating an empty “config” folder in the “2.80” folder).

Link to the post? I

Broken here as well. I suspect this bug may be related to the surface selection issue.

Can’t redo this bug/feature with Smart Select, so I dunno? :smiley:

The gumroad page and this vimeo channel.

It was Load Factory Settings with the previous Version of Blender. If I do a Load factory Settings with 79f67accc36 it works but I loosing of course all my configurations and need to do it again from scratch which sucks.^^

So I will probably do a factory reset after the release of Blender 2.8 and do all the configuration again there.