Smart Select - 1.4.4 This update fixes the install issue and select mouse problems

Okay i just updated Smart select to 1.4.3 on Gumroad. All buyers should get the new update in their mails. In this version the selecting issues should be fixed. Try it out and don’t forget to thank Nburn for his heroic work!

1 Like

Wow, guys - brilliant work on update 1.4.3! And perfect timing, too, as I’ve just started a big project today that is going to seriously benefit from the fancy selection options of Smart Select! I’ve only done a handful of tests this morning before I dive into a proper work project, but every issue that I experienced in previous builds appears to be resolved (using today’s build of 2.80beta) - fantastic! Thanks so much for your hard work and troubleshooting!

1 Like

This occurs when attempting to activate smart select. It seems to work fine with a clean default blender but it breaks as soon as I switch from default keymap to industry compatible keymap.

Great update! Seems like the problems have been fixed.

Does fill selection still work, or does it need to be reimplemented for 2.80? I can’t seem to get it to work.

i got the update testing it out thank you i miss this tool

hope SMART FILL gets an update too

1 Like

Glad to hear it!

Hmm… It seems like getting whatever the user set up for mouse selection is no longer possible in 2.80 and will have to be hardcoded. :\ I will have to put this on my todo for the next update. If you want a quick fix, just make these changes to preferences.py in the smart select addon folder (the red is lines that get removed, green is lines that are added).

--- smart_select_1.4.3\smart_select\preferences.py
+++ smart_select_1.4.4\smart_select\preferences.py
@@ -130,15 +130,11 @@
     hkw2 = pr.hotkey_wheel2

     if hk.key == 'NONE':
-        sel = bpy.context.window_manager.keyconfigs.active.preferences.select_mouse
-        sel = sel + 'MOUSE'
-        #hk.key = 'RIGHTMOUSE'
-        hk.key = sel
+        hk.key = 'LEFTMOUSE'
         hk.alt = True
         hk.value = 'PRESS'

-        #hkt.key = 'RIGHTMOUSE'
-        hkt.key = sel
+        hkt.key = 'LEFTMOUSE'
         hkt.alt = True
         hkt.shift = True
         hkt.value = 'PRESS'

It should be working now, I tested this before release. For me it was press ALT + SELECTMOUSE then drag the cursor while those two buttons are pressed. I think that’s the same as it was in earlier versions. By default it should be press Alt + Selectmouse over the part of the mesh you want to fill and then hold those keys down for a few seconds afterword (thanks @JTenebrous).

b280_test01

I’ve done some work on Smart Fill, but haven’t been able to get it running on 2.80 yet. An update for that might be a ways off as I have a lot going on at the moment.

2 Likes

The command to perform Fill Selection, in the original version, was (HOLD) Alt + Selectmouse. After a hold delay of about 1 second or so, the fill occurs. It still seems to work that way in the current version - I haven’t noticed a change at my end. :slight_smile:

2 Likes

@JTenebrous Thanks! It’s the delay that got me, I don’t remember it being like that back in 2.79, but it’s fine; just glad to have the functionality.

Some text documentation of all the features in their current state would help new users out.

1 Like

I tried to install smart select 1.4.3 on my blender 2.8 , but it can’t be found in Preferences-Addons after I installed it.
I can find it in the BlenderConfig document , and I tried to Refresh Preferences-Addons , but I can’t find it in Preferences-Addons.
My system is Linux Mint

I found the reason, put the “smart select” document out of “smart select 1.4.3 document” in BlenderConfig document , it worked.

I get an error installing it in latest version of Blender.

please post the error

smart angle doesn’t work on latest blender 2.8 version, I tried to set Ctrl ,Shift for the short key , but it doesn’t work. Do you have problem with it ?

For whatever reason installing the zip file provided which doesn’t have a proper structure it was giving me the error even moving the files to the smart_select root folder manually. Anyway it works now.

Thanks for these reports, it looks like something went wrong when packaging the latest 1.4.3 release. The smart_select_1.4.3.zip file should have archived a single “smart_select” directory containing all the files and sub-directories the add-on uses. Instead, it archives a “smart_select_1.4.3” parent directory which has the “smart_select” directory inside. I’ll work on getting a corrected version of Smart Select to Gumroad.

I’m not having this problem locally. I just tested with the:
May 12, 00:06:24 - ebc44aae9897 build from yesterday. No issues for me when setting the “Change Angle Hotkey” to Ctrl + Shift + Mousewheel and then using those keys to do a “selection angle change” after using the Smart Select Hotkey(s).

I get a crash when doing alt-dbl click on edges. How would I give you more information about it? Doesn’t that happen on your end? Using 2019-05-12 build.

I am not sure what you mean by 2019-05-12 build. I did have some crashes with some of the recent 2.80 builds, but I those crashes seemed to be caused by Blender and not Smart Select. I just tested Smart Select (1.4.3) with today’s daily build (the Windows 64 build of commit hash 3076544c8c52) and was not getting any crashes.

As an FYI, if you are trying today’s 2.80 build, note that the Blender devs decided to hide the preferences option behind the blender icon on the top left corner of the screen instead of the edit drop down. Clicking on that icon in earlier versions of Blender would just bring up the splash screen.

It means the daily build date. Will download today’s.

My system is Linux Mint 19 , Change Angle Hotkey doesn’t work, it works on earlier version of blender 2.8 linux, but it doesn’t work now.

Ah, that makes sense. I was having crashes with a 5-12 build as well, I think specifically it was the May 12, 00:06:24 - ebc44aae9897 build I mentioned earlier.

Are you still having this problem with the latest daily? I have not had this issue in the most recent build I’ve tried. If you’re still having a problem with the latest daily, I need the specific commit hash for the build (you should be able to find this on the Splash Screen) and, if possible, any error messages that were dumped to the terminal (you have to launch Blender from a terminal window to get this info).

For the Splash screen: