Smart Select - 1.4.4 This update fixes the install issue and select mouse problems

Thanks a lot for those comments! I might actually use those quotes =P

There will be a lot of more features implemented, i am working on them right now. Don’t forget to spread info in every way you can if you like this addon, it will help a lot for sure.

Thanks, you’re right!
Unchecked and reinstalled, now is back to normal.

Just for the record I have blender 2.78 and Smart Select 1.2.0.
Thanks again!

Nice update, that made me pull the trigger on that one :slight_smile:

Great to hear! Please let me know what you think is good and bad, and same for everyone else!

Buy a nice addon, thanks

Seems to cause a crash in blender with undo.

Do you get an error report or does ir just crash? Whar Blender version are you using? Have you tried using the addon on a clean Blender build?

Thanks for the feedback, i plan to go back and really clean up this script some more so if you find any more issues let me know and i will look into those aswell.

It just crashes. Does not seem to happen when the addon is disabled. Blender 2.78a

I am using the same version as you and never get any crashes. I will dig into this further.

Another beauty, thank you Jim!

Glad you like it!

I am writing up all the bugs i can find at the moment so let me know if you find any, especially with the undo function, anyone else than John Lancaster having any problems with this?

Hi, I just bought this one, loving it, but Im also getting a crash when using undo. I use OSX, on a fresh 2.78.
It’s a hard crash for me as well. For me it seems to be a combination of using any modifier + bevel, changing the amount of segments and then undoing during the bevel (before committing.) So exactly like this:

  1. Create a cube
  2. Add a modifier, the ones ive tried with that crashed are Subdivision Surface, and it also crashed with Edge Split & Solidify. Could be crashing with any modifier but not sure.
  3. Select a edge, or a edge loop (i dont think it matters? Ive tried mostly with edge loops)
  4. Bevel the edge, and change the amount of segments.
  5. Before committing, while still in the tool, UNDO. It crashes.

I can reproduce this a 100% every time using this procedure.

Thanks for the feedback i will look into this for sure!

Any chance we will get any bugfix on this? :slight_smile: Been needing to use the tool recently…

I am working full speed on trying to get my latest addon Smart UV to be updated, we are still waiting for some code to be changed in Blender thaty would make it easier to fix bugs for all of my scripts. What bugs are you having? Can you write them up and make some clear examples of the bugs, it would make it a lot easier for me. Thanks for the feedback!

Yes, sure if you go up two messages, you have my full bug report there :slight_smile:

Sorry about that, i just haven’t looked on this tread for awhile. If i am not mistaken i asked over ten people to find a similar bug like you and no one could find them.

He mentioned it was on OSX, have you had someone try it on that operating system? I’ve seen other addons with Mac specific issues. I can try to reproduce on mine tonight if you want.

Yeah please do that would be great!

Using Smart Select 1.2.0 and Blender 2.78a on OSX 10.10.5, I couldn’t reproduce his crash(nor even finish recreating it, it doesn’t let you hit undo during bevel). I did get some other crashes when I first started but now they’ve gone away and I can’t get them to happen(of course it’s when I’m running out of a terminal and could get a possible error message). I’ll keep messing with it for a bit.

One thing I’ve noticed that seems wrong is that Smart Select doesn’t realize when a regular selection event has taken place and the operator should go away. This maybe a contributor to existing or future trouble. For example, if you select the loop of edges on the top of a cube, then just normal right click an unselected edge, then change the mode with alt-scrollwheel, the selection reverts to the original loop with the new mode. This behaviour might be related to the next thing as well.

Also, I may have found a different bug that happens on Windows and OSX though:

  1. Create a cube
  2. Hit Tab to enter edit mode, change to Edge Select mode if necessary
  3. Alt-RMB to select a single edge
  4. Alt-scrollwheel(or ctrl-scrollwheel) over a different edge to change mode/angle, you lose your selection and the edge you’re hovering over is selected.

This doesn’t seem like intended behaviour if alt-scrollwheel is just supposed to be a mode select.