Smart Select - V. 1.4.0 - Beta for Blender 2.80 updated by Nburn is now out!

add-ons
blender2-80

(jimpaw80) #162

Great, keep digging and trying, here are my settigs inside smart select:


(Nomo) #163

Do you have right select enabled @jimpaw80? Perhaps as Dheim mentioned, the issue could stem from the fact that we are using left click to select. And if so, I’m wondering if left-click support is something you guys will consider, especially with Blender defaulting to left-click select.


(jimpaw80) #164

I select with left. can i share my screen on Skype? Maybe we can compare?


(Nomo) #165

I’m unavailable for skype at the moment, but perhaps @Dheim can chime in.


(jimpaw80) #166

I asked him before to :wink: I managed to get an error aswell when i switched from Blender to Blender 27x


(jimpaw80) #167

BTW have you tried to change deom “select mouse” to left or right? i mean clicking on that box inside smart select preferences?


(Nomo) #168

I was able to install the add-on by switching my keymaps to Blender and switching back to my personal keymaps. @Dheim. I’ve yet to test if it works, but will report back in a bit.


(Nomo) #169

@jimpaw it’s working, but for me smart select seems to be selecting behind a face as well, creating unwanted selections and unpredictable usage of the addon.


(jimpaw80) #170

Yeah i am so glad you mentioned that aswell it seems to select “throught” the model right?


(Nomo) #171

Yes. so a double select triggers a weird struggle among loop selection of two different faces and flat selection.


(jimpaw80) #172

yeah it seems that right now the loop select get’s to much power, way to ofter it takes over.


(nBurn) #173

Weird, I still can’t make this bug show up. Do you and @Colacuve mind uploading the userpref.blend file being used when the error appears?

It will be in Blender’s executable directory if you created a “config” folder here:
blender-2.80-blah\2.80\config

Or at somewhere like this (if you’re on Windows 10)
C:\Users\USERNAME_HERE\AppData\Roaming\Blender Foundation\Blender\2.80\config

The location will be displayed in the console after you click “Save Preferences” in the Preferences window:
Writing userprefs: C:\Users\USERNAME_HERE\Path\To\blender-2.80-blah\2.80\config\userpref.blend' ok

Another option might be Exporting your Keymap settings. Blender will save them as a “.py” file.

The selecting behavior in Blender was rewritten with the move from Blender Internal to EEVEE and changed something. I’m aware of the issue, but haven’t found a solution yet.


(Dheim) #174

Sent you a private message. Thanks!


(JTenebrous) #175

Hi JimPaw80 and nBurn . I’ve just installed the recent beta version. I’m running Blender 2.8 beta daily build from 02Feb2018 on Windows 10 (I update builds roughly every fortnite). I’m running on a 4k display, with 125% Windows Display Scaling, and 125% UI scaling inside Blender. I’m using Left select with new standard Blender hotkey map.

Initially, everything seemed to install and work as expected. So at least things are off to a good start. However, I soon confirmed that, I too, am experiencing the same issue reported by Colacuve . Alt-Clicking on a face seems to trigger a loop select that is far offset from where I’m clicking. However, when I move my mouse, it seems to select a different loop. That’s why I’m suspecting maybe the various windows display and UI scaling is part of the issue. However, I can’t really run a 27" 4k display without any upscaling, so hopefully this can be resolved (if, indeed, it’s at all connected).

Also, I will quickly add that loop select seems to work if I alt-left click directly on an edge (while in face, edge, or vertex select mode). It only makes strange selections when I alt-click more centrally on a face while in any of the selection modes. Vertex select mode seems to work most reliably, but I guess I’m usually clicking on a specific vertex in that mode.

Good luck! This tool is so useful when it’s in full working order! :slight_smile:


(jimpaw80) #176

Man thanks for some stellar feedback!


(Shiv0r) #177

Windows 10
image

I getting an error message if i trying to install the addon:
image

I also tested it with the current available build from https://builder.blender.org/download/ I still getting the error message.

Cheers!


(obsurveyor) #178

Sounds like this is a bug in the current builds of Blender. You may have to unzip it manually.


(FrankieH) #179

I can’t seem to make this add on work while in wireframe mode, is there any fix for that?
I also wish you could click off the mesh while in solid mode (like you can for standard loop select)

I’m on 1.3.2 and blender 2.79b fwiw

apart from that I love the plugin, good job :+1:


(Shiv0r) #180

Heyho,

it still breaks the toggle selection hotkey:


image


(obsurveyor) #181

That is probably a new bug since they merged tweak and drag thresholds into one value. Addon has to be updated for current builds.