Smoke appears pixelated

I’m rendering a smoke animation and it seems to be pixelated despite experimenting with the settings below. I’ve added the .blend file and a video to show the effect I’m seeing after a very high quality render.

I’m happy with how the smoke looks, I just need to get rid of the grain/pixelated effect

I’ve been through the forums and used the following settings:

  • In smoke domain, divisions are set to 64, density at 0, temp diif at 0.1, dissolve (ticked)
    -smoke adaptive domain turned off
    -smoke high resolution turned on (divisions at 1, wavelet
    -I’m using cycles render with the principled volume shader, everything is at default except the density which is keyframed
    -When rendering I’m clamping the light at direct(8) indirect (6)
    -All caustics turned off
    -glossy to 0.05
    -I tried the denoiser but couldn’t see a noticeable difference so turned it off.
    -There is also a flame in the scene. I’ve left it in just in case it could be affecting something

Thank you

steam-spray.blend (850.6 KB)

I think this grain is caused by the cycles rather than the resolution of the smoke.

Can I ask you - is smoke and flame rendered separately from the rest of the scene? If so, you can blur a little ( about 8 pixels) - this looks OK on smoke, cos it’s kinda blurry anyway.

Also, there’s this button (below) that means that cycles puts it’s cycles grain in a different place on each frame, meaning that it acts more like film grain rather than a non-moving overlay.


Thank you for your reply. Could you please elaborate on what you mean by ‘blur’ and how I would do this just for the smoke?

I’ve tried increasing the step size to 3 and the results still look noticeable grainy/pixelated.

Any further suggestions would be much appreciated.

You can blur in compositing nodes…

Also - turning up the render samples should help with the grain, but it will render slower.