Smoke artifacts :(


(dafassi) #1

Hi at all - whenever im going to simulate smoke i ran into artifacts in the final rendering. Its exact the same probleme like here: https://blender.stackexchange.com/questions/76126/strange-lines-in-smoke-rendering-with-cycles
But i cannot find any solution.
The domain-scale has been applied!
Anyone?


(English is not my native language) #2

Hi
Could you share a .blend file with the scene? Edit: Ok, I have file from youtube link :slight_smile:
Are CPU and GPU render the same?
What value are you using for Resolution > Divisions in smoke domain?. Edit: seems 256 like in the other link


(dafassi) #3

Okay i made a new scene. Hopfuly someone can help me to find what im doing wrong here.
ViewPort:


Renderd:


BLEND: https://www.dropbox.com/s/rxt5xsij2h5ji4a/Smokyfacts.blend?dl=1


(dafassi) #4

Here is another one:

BlendFile: https://www.dropbox.com/s/6zt1rkdpvqrbu1b/Smokyfacts2.blend?dl=1


(English is not my native language) #5

Hi
Maybe report on tracker for developers to decide if this is a bug or something we are doing wrong?
I’ve searched on google and people mention artifacts or square artifacts over there, but not on tracker.

By the way, I’m not sure but I’d like to try bake the simulation with multithreading disabled. I am not sure if it is possible to globally disable multithreading in Blender.


(dafassi) #6

Ive reported it as “maybe bug”, now.
Im not able to disable MT. Baking in general does not change anything.
Ill wait if some developers can help and report here ;).
Thank you YAFU!


(English is not my native language) #7

I have the proof where developers tell me that when in doubt about whether the problem might or may not be a bug, it is always advisable to do the report :slight_smile:

I have no idea about technical issues. It came to my mind that this could be a bad multi-thread implementation. I think this is because I remember that some similar artifacts appeared in images when multi thread was introduced in G’MIC filter for GIMP.

I saw in the report that you did test with 512 resolution. Can I ask what CPU do you have? My i7 3770 suffers very much


(dafassi) #8

Im working with a i7-5820k (6x3,4GHz) and 32GB RAM.
Ill do some other tests, too. If i find any solution or developers can help ill let you know!


(gritche) #9

try incrase subframe sampling on the sphere…


(gritche) #10


tweak the density with a ramp should help too, like this


(dafassi) #11

Hey Gritche, ive just tested this with subframes 50. There is nearly no differenece overall. But it was a good tip in general!
You NodeSetup didn´t solve this issue- but it makes visible where the artifact are coming from! It because my smoke is very blocky …